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Address Autocomplete 

IP-5125 – Address Autocomplete Functionality [beta] 

This function adds the ability to utilise the Address Autocomplete function which has been implemented on the 

Customers, Suppliers, Clerks and Pending Sales screens. 

As an address is entered into the address field of any of the abovementioned screens, Idealpos will dynamically display 

a list of suggested addresses that match the input that has been entered so far.  

Once the user sees a suggested address on-screen that matches the complete address they are entering, they can click 

on the address in the list and Idealpos will populate the entire address into the Address, Suburb, State and Postcode 

fields.  

 

This function is enabled via a licensed module based on the number of lookups performed per month. 

Once this module has been enabled in the Licence, no further configuration is required, and the function will be 

available after performing a Close Suite/Open Suite; contact our sales team for further details about purchasing this 

module. 

 

Once this function has been enabled in the Licence Gateway, the function will be available in the following screens:  

 

• Customers (Back Office > File > Customers > Customers > Add/Modify) 

• Suppliers (Back Office > File > Suppliers > Suppliers > Add/Modify) 

• Clerks (Back Office > Setup > Clerks > Add/Modify) 

• Pending Sales (POS Screen > Add Items to Sale > Pending Sale Button, or POS Screen > Pending Sale Button 

> Select Pending Sale > Modify) 

 

When entering part of a Customer Address, the suggested addresses will be displayed: 
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After an Address is selected, all Address fields are populated with the selected address. 
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Bookings 

IP-5212 – TicketSocket Interface 

This function enables the integration of the TicketSocket Interface in Idealpos. 

TicketSocket is a white label ticketing and registration control interface that enables the redemption of TicketSocket 

tickets via the Idealpos POS Screen. 

TicketSocket will customise their ticketing solution for your brand using your company logo and to suit your 

requirements. 

 

Once this has been done, TicketSocket can be enabled in Idealpos so that TicketSocket Tickets can be redeemed from 

the Idealpos POS Screen. 

 

As this is an integration that is tailored for specific customers, the process for configuring and using TicketSocket with 

Idealpos is outlined in the User Guide. 

In the User Guide, go to: Bookings > TicketSocket.   

https://userguide.idealpos.com.au/
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EFTPOS 

IP-5182 – Support for Paymentree Prepaid/Partial Payment 

This function adds support for Paymentree Prepaid/Partial Payment. 

When a Prepaid card with a limited balance is used to make a partial sale payment through Paymentree, the partial 

payment will now correctly apply to the sale in Idealpos.   



 Update History 
Return to top 

Idealpos 8 Build 10 - Update History Page 6 of 63 

 

Export Data 

IP-5127 – Stock Items Export – Support for Promotion Description 

This function adds the ability to include the first Promotion that references a Stock Item in the Stock Item Export.  

Note that the Priority Order of your Promotions DOES NOT affect which Promotion will be displayed in the Stock Item 

Export. Idealpos will export the first Promotion that it finds which references the Stock Item. 

 

The logic that determines which Promotion Description will be exported is as follows: 

The description of the first Promotion that is found which references the Stock Item will be exported. 

If a Promotion cannot be found which directly references the Stock Item, it will then export the first Promotion that 

references the Departments. 

Promotions which link to ‘All Items’ or ‘Any Item’ will not be exported. 

 

The below contains a few examples and which Promotion description will be exported: 

 

• Stock Item is directly referenced by multiple Promotions – The description of the first Promotion that 

references the Stock Item will be exported.  

• The Stock Item’s Department is referenced by a single Promotion AND the Stock Item is also directly 

referenced in another promotion – The description of the Promotion that directly references the Stock Item 

will be exported. 

• The Stock Item’s Department is referenced by multiple Promotions – The description of the first Promotion 

that references the Stock Item’s Department will be exported. 
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To use this function, go to: Back Office > Utilities > Export Data > Stock Items 

Export: Specific Fields by Range or Automatic Export Format 

 

Export Folder: Enter a folder location where the exported data should be written to (e.g. C:\Export) 

Filename: Enter a filename for the exported data (e.g. StkItems.txt) 

Enable the required checkbox options (e.g. Append Date/Time to filename, Include Headers). 

 

Export Specific Fields by Range: Select the fields required. 

To demonstrate this function, the following fields have been selected: 

1: CODE 

2: DESCRIPTION 

3: DPT 

4: DPT DESCRIPTION 

5: PROMODESCRIPTION 
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If required, the ‘Save Defaults’ button can be pressed on the top-left corner so that each time this function is used, it 

will be pre-filled using the selections that have been made. 

Press the ‘OK’ button to export the data. 

 

If Automatic Export Format was selected, press ‘Save Format’ to save the change. When the Automatic Export runs, the 

Promo Description will be included in the exported data. 

 

While the data is being exported, a progress bar will appear at the bottom of the window. 

 

 
 

Once complete, an ‘Export Complete’ prompt will be displayed. 
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The Exported Data will contain the Promo Description, similar to the below example: 
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Function Descriptors 

IP-5114 – Tender Functions – Give Change in Local Currency option 

This function will enable a Tender to be over-tendered and give the change in CASH. 

 

To configure this function, go to:  

Back Office > Setup > Function Descriptors > Select a Tender between TENDER 2 and TENDER 18 > Modify. 

Toggle the checkbox ‘Give Change in Local Currency’ as required. 

 

Note that the following logic applies to each tender when over-tendering: 

Cash Tender – When over-tendered, change is given in Cash. 

EFTPOS tender – When over-tendered, change is given in Cash. 

Credit/Non-Credit Tender – Does not give change, unless the ‘Give Change in Local Currency’ option is enabled. 

 

Press the ‘Save’ button on the top-left corner of the Modify Function Descriptors screen to save the change. 
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Ideal Handheld/Pocket Pad 

IP-1790 – Ideal Handheld – Support for Orders to show in Journal History 

This function enables orders placed to tables via Ideal Handheld/Pocket Pad to appear in the Journal History Enquiry. 

This can be useful for tracking the placement of orders to a table. 

 

This function does not need to be enabled nor require any additional configuration. 

 

From Ideal Handheld or Pocket Pad, select a Table from the Table Map and press ‘Start Order’. 

 

 
 

If prompted, enter the number of Covers > OK 
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Add Items to the order > Send > Finalise 

 

 
 

Press Send Order 
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Success – Order Sent 

 

 
 

Go to: Back Office > Enquiry > Journal History 

The order will appear in the Journal History Enquiry. 
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The Activity Log will also show that the Table was sent to the Kitchen (Table # (WP) sent to Kitchen). 

 

Go to: Back Office > Enquiry > Activity Log. 

The Table number and (WP) will appear as being sent to Kitchen. 

 

 
 

    



 Update History 
Return to top 

Idealpos 8 Build 10 - Update History Page 15 of 63 

 

Import Data 

IP-3730 – Metcash – Support for new ALM Invoice DAT format 

This function adds the ability for Idealpos to support the importing of files using the new ALM (Australian Liquor 

Marketers) Invoice DAT format files which are supplied by Metcash. 
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Kitchen Dockets 

IP-5188 – Kitchen Printing – Option to Accumulate with Instructions (Order by Print Group) 

This function adds the ability to enable Accumulate Items with Instructions. 

Previously, it was possible to only enable Accumulate Items which would accumulate Stock Items on the Kitchen 

Docket, but if any Instructions were added, then the Stock Item and Instructions would not accumulate. 

 

The ‘Accumulate Items with Instructions’ option is now available when using the following Kitchen Docket Formats: 

• Order by Print Group 

• Order by Seat/Print Group 

• Order by Print Group/Seat 

 

When enabling this option, the Accumulate Items option must be enabled first which will then trigger the ‘With 

Instructions’ option to appear so that it can be enabled. 

When both ‘Accumulate Items’ and ‘with Instructions’ are enabled, multiples of the same Stock Item with the same 

instructions will be accumulated. 

It should be noted that when an item contains more than one instruction, the Stock Item with instructions will only be 

accumulated when the instructions are added in the same order to each item. 

 

Example 1: Instructions are added in the same order for each item. 

A Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

Another Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

 

In this example, both Cappuccinos with the instructions will be accumulated, as the instructions have been added in 

the same order for each of the Cappuccinos that were added to the sale. 

 

Example 2: Instructions are added in a different order for each item. 

A Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

Another Cappuccino is added to the sale, then the instructions Extra Choc, then Extra Hot are added. 

 

In this example, the Cappuccinos will not be accumulated as the instructions for each Cappuccino were added to the 

sale in a different order. 
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To configure this function, go to:  

Back Office > Setup > Global Options > Printing > Print Formats > Kitchen Docket Format 

 

Select one of the following Kitchen Docket Formats: 

• Order by Print Group 

• Order by Seat/Print Group 

• Order by Print Group/Seat 

 

To demonstrate this function, the ‘Order by Print Group’ function will be selected. 

Enable ‘Accumulate Items’.  

Enabling ‘Accumulate Items’ will trigger the ‘With Instructions’ option to appear.  

Enable ‘With Instructions’. 
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Close the Global Options window, then go to POS Screen. 

 

Add the following Stock Items and Instructions in the following order: 

Cappuccino > Extra Hot > Extra Choc 

Cappuccino > Extra Hot > Extra Choc 

 

 
 

The items will appear in the sale window similar to the below example when added in the order listed above. 
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Finalise the sale by pressing Enter > Select a Tender. 

Alternatively, save the sale to a table by pressing the Table Map button > select a table > enter number of covers > OK 

 

When the Kitchen Docket is printed, the Stock Item and the Instructions will both accumulate as per the example 

shown in the below Kitchen Docket printout. 

 

 
 

If the same items are ordered with the ‘With Instructions’ option disabled, the items will print to the Kitchen Docket as 

follows (no accumulation): 

 

 
 

Additional examples of Kitchen Dockets for each of the Kitchen Docket Formats [Accumulate With Instructions] can be 

found in Print Formats section within the Global Options > Printing topic of the User Guide.  

https://userguide.idealpos.com.au/Content/Global%20Options/Printing.htm#Print_Formats
https://userguide.idealpos.com.au/Default.htm#Global%20Options/Printing.htm
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IP-5189 – Entire Order to Triggered Kitchen Printers – Order by Print Group Formats 

This function adds the option ‘Print Entire Order to triggered Kitchen Printers’ to the Order by Print Group Formats. 

Prior to this change, the option ‘Print Entire Order to triggered Kitchen Printers’ was only available when using the 

Kitchen Docket Format ‘Group Instructions by Seat’. 

 

The ‘Print Entire Order to triggered Kitchen Printers’ is now available when using the following Kitchen Docket Formats: 

• Order by Print Group 

• Order by Seat/Print Group 

• Order by Print Group/Seat 

 

When the ‘Print Entire Order to triggered Kitchen Printers’ is enabled with the ‘All Options’ option selected, the entire 

order that was placed will be printed to all Kitchen Printers that have been triggered. 

For example, there are four separate Kitchen Printers: Mains, Pizza, Pasta and Bar. 

There are four items in these Sales Categories:  

Main [Food Sales Category] 

Pizza [Food Sales Category] 

Pasta [Food Sales Category] 

Beer [Beverage Sales Category] 

 

Example 1: An order is placed that only contains a Pizza – Only the Pizza will print to the Pizza Printer. 

Example 2: An order is placed that contains a Pizza and Pasta – Pizza and Pasta will print to the Pizza Printer and Pasta 

Printer. 

Example 3: An order is placed that contains a Pizza, Pasta and Main – Pizza, Pasta and Main will print to the Mains 

Printer, Pizza Printer and Pasta Printer. 

Example 4: An order is placed that contains a Pizza, Pasta, Main and Beer – Pizza, Pasta, Main and Beer – Pizza, Pasta, 

Main and Beer will print to the Mains Printer, Pizza Printer, Pasta Printer and Bar Printer. 

 

To prevent Food Items from being printed to the Bar Printer, the ‘Food’ Sales Category can be selected. 

When the ‘Food’ Sales Category is selected, the system will behave the same way as described in the examples above 

except for example 4.  

 

Example 4 when Sales Category is set to ‘Food’ (order is placed that contains a Pizza, Pasta, Main and Beer) – 

Pizza, Pasta and Main will print to the Mains Printer, Pizza Printer and Pasta Printer. The Beer item will only print to the 

Bar Printer. 
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Go to: Back Office > Setup > Global Options > Printing. 

In addition to the existing Kitchen Docket Format ‘Group Instructions by Seat’ which already contained support for this 

function, the options which can now utilise this function are shown in the below examples: 
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POS Screen Setup 

IP-5179 – POS Screen – New Customer Function 

This function adds the ability to create a POS Screen button linked to the New Customer Function, enabling the Clerk 

direct access to the New Customer Function via a dedicated POS Screen button. 

Prior to this enhancement, the New Customer Function on the POS Screen could only be accessed via the Customer 

Search button > New Customer. 

 

To configure and use this function, go to:  

Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

 

Click on the desired POS Screen Tab where a button for this function is required, then locate a blank button and 

configure it as follows: 

 

Function: New Customer 

Button Caption: New Customer 

Configure/Customise the button appearance as desired. 

 

Press ‘Save’ to save the button. 
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Close the POS Screen Layout windows, then press the ‘POS’ button from the Back Office Dashboard. 

Click on the POS Screen tab that contains the button and press it. 

 

The New Customer function is displayed on the POS Screen. 
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Enter the New Customer’s details, then press ‘OK’. 

The only compulsory field is the Last Name, however, it is recommended that all possible details be entered in the 

event that the customer needs to be contacted. 
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The Customer record is created, then the customer is added to the sale. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 10 - Update History Page 26 of 63 

 

This function also obeys the Yes/No Option ‘Fast Customer Modify can modify Credit Limit’, and when enabled, the 

Credit Limit field will be displayed on the New Customer screen. 

To enable this function, go to:  

Back Office > Setup > Yes/No Options > Search: credit limit > Enable ‘Fast Customer Modify can modify Credit Limit’. 

 

 
 

When this Yes/No Option is enabled, the New Customer screen will display a Credit Limit field which can be used to 

enter the Customer’s Credit Limit. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 10 - Update History Page 27 of 63 

 

In addition to the Credit Limit field, the Customer Code field can also be displayed as an editable field on the New 

Customer screen. To display the Customer Code field, enable the Yes/No Option ‘Fast Customer – New Customer Code 

Field’. 

Go to: Back Office > Setup > Yes/No Options > Search > ‘new customer code’. 

Enable the Yes/No Option ‘Fast Customer – New Customer Code Field’. 

 

 
 

The New Customer screen will display the Customer Code field. 
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POS Terminal Settings 

IP-5178 – Customer Display – Option to show Customer Account Balance 

This function adds the ability to show the Customer Account Balance on the Customer Display Screen. 

This function requires that the POS Terminal has a Customer Display Screen configured and enabled. 

This function is only available on the following Display Formats: 

• Small Sales with Company Logo 

• Full Height Sales with Company Logo 

 

To enable this function, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

In the Display/Kiosk tab, enable the ‘Show Customer Balance’ checkbox. 

As mentioned above, this function is only available on the Small Sales with Company Logo or Full Height Sales with 

Company Logo Display Formats. 
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Close the POS Screen Setup window. 

From the Back Office Dashboard, press the ‘POS’ button to display the POS Screen. 

Add a Customer to the sale via the Customer button. 

The Customer’s Balance will be overlayed over the Company Logo portion of the Customer Display Screen. 

 

 
 

For the above Customer Display example, the Customer’s record appears as follows on the POS Screen. 
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Reports 

IP-5153 – A4 Invoices – Override Header/Footer Image by Customer Type 

This function enables the ability to override the Header and/or Footer Image that is displayed on the Customer’s 

Invoice, based on the Customer Type that the Customer is associated with. 

A custom header image can be set for cases where you may want to display a custom rewards club branding graphic 

or similar which reflects the Customer Type that the customer is linked to. 

A custom footer image can be set for cases where you may want to list different payment details for each Customer 

Type, along with any graphics or imagery that are specific to the Customer Type that the customer is linked to. 

 

The way this function works is that if an Override Header and/or Footer Image has not been set for the Customer Type, 

then Idealpos will use the Header/Footer Image that has been configured in the Global Options. 

If an override image is not set and an image is not specified in the Global Options, then no image will be shown on the 

Customer’s invoice. 

 

To configure this function, go to: Back Office > Setup > Global Options 

Ensure that a Company Logo Graphic (displayed on the Invoice Header) and Invoice Footer Graphic are selected. 

The images should be in the Idealpos Pictures folder, which is located here…  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures 

 

The maximum pixel size of the Company Logo image can be 330 pixels wide x 90 pixels high. 

The maximum pixel size of the Invoice Footer Graphic image can be 710 pixels wide x 192 pixels high. 
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Close the Global Options window to save any changes. 

The images specified in Global Options will be used when an Invoice is produced for a Customer that belongs to a 

Customer Type which does not have an Override Header/Footer Image configured. 

 

To configure the Override Header/Footer Image by Customer Type, go to: 

Back Office > File > Customers > Customer Types > Select a Customer Type > Modify 

 

Specify the filenames of the override images in the A4 Invoice Override Header Image and A4 Invoice Override Footer 

Image fields. In the same way as the images were configured in Global Options above, the images must be placed in 

the Idealpos Pictures folder which is in C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\. 

The maximum image resolutions are also the same as they were for the images that were configured in Global 

Options. 

The maximum pixel size of the A4 Invoice Override Header Image can be 330 pixels wide x 90 pixels high. 

The maximum pixel size of the A4 Invoice Override Footer Image can be 710 pixels wide x 192 pixels high. 
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After the Override Header/Footer Images have been selected, press the ‘Save’ button. 
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Close the Customer Types window, then go to: 

Back Office > Reports > Customers > Customer Invoices 

Specify the selection criteria for the Customer Invoices Report and press ‘View’. 

 

Any Customers that are linked to the Customer Type containing the overridden Header/Footer Images will display 

those images on their Customer Invoices. 
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Customers/Cash Sales that are not linked to a Customer Type which does not have an Override Header/Footer image 

configured will display the standard images that are configured in the Global Options. 
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IP-5194 – Stock Item Sales Report – MDI Functionality [beta] 

This function adds MDI (Multiple Document Interface) functionality to the Stock Item Sales Report. 

This means it is now possible to run a Stock Item Sales Report, then resize the full screen report to a smaller window.  

This functionality will enable multiple Stock Item Sales Reports to be run concurrently, making it possible to compare 

reports side-by-side on the same screen.  

In addition, the ability to access other Idealpos Back Office functions is now possible while viewing the Stock Item 

Sales Report. 

While it is possible to reposition the Stock Item Sales Report on a screen running at a resolution of 1024x768 and 

access other Back Office functions, it won’t be possible to display multiple Stock Item Sales reports side by side on this 

resolution. 

Therefore, a resolution of 1920x1080 is recommended to utilise this function. 

Even greater usability of this function can be attained by using a screen resolution of 3840x2160 on supported 

monitors. 

 

To use this function, go to: Back Office > Reports > Sales > Stock Item Sales 

Specify the required selection criteria and press the ‘View’ button on the top-left corner of the Stock Item Sales 

selection criteria window.  

On larger resolution screens, the Stock Item Sales Report selection criteria window will be displayed as a window, as 

shown in the below example: 
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After pressing ‘View’ on the selection criteria window shown above, the Stock Item Sales Report will be displayed as a 

full-screen window. 

Press the resize button located on the top-right corner next to the close button to resize the report to a smaller 

window. 

 

 
 

After resizing the report to a window, other Idealpos Back Office functions can be accessed. 

To drag the Stock Item Sales Report window to another location on the screen, position the mouse cursor into the 

area shown, then click and hold the mouse button and drag the window to the desired location on the screen.  

Release the mouse button to drop the window to the position. 
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After repositioning the Stock Item Sales Report window, menu options in the Idealpos Back Office can be clicked to 

access other functions. 

 

 
 

It is also possible to run multiple Stock Item Sales Reports and display them side-by-side. 

Click onto the Stock Item Sales window to bring focus back to the Stock Item Sales Report selection criteria screen. 

Modify the Stock Item Sales Report selection criteria and press ‘View’ to run another Stock Item Sales Report. 
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Another Stock Item Sales Report window is displayed. 

Resize the window using the resize button on the top-right corner of the report window (next to the close button). 

Two Stock Item Sales Reports are now displayed on-screen. 

The Stock Item Sales Report windows can be dragged around on the screen and repositioned side-by-side so that they 

can be viewed concurrently for comparison. 

This process can be repeated as many times as required; there is no limit to the number of concurrent Stock Item Sales 

Report windows that can be displayed concurrently. 

 

 
 

Note that the main Stock Item Sales Report selection criteria window can also be closed, and any Stock Item Sales 

Reports will remain on-screen. 
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Any Report Shortcuts (created by pressing the ‘S’ button on the top-right corner of the report) will also support the 

MDI (Multiple Document Interface) functionality when running reports via the Back Office shortcut. 

 

Create the report shortcut by pressing the ‘S’ button on the top-right corner of the report. 

 

 
 

Enter a Shortcut Name, select the Shortcut Group, then press ‘Save’. 

 

 
 

The report is added to the Favourite Reports. 
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Selecting the Shortcut from the Favourite Reports will run the report and the report will contain the resize button, 

enabling the report to be resized and making it possible to run additional reports side-by-side, or access to other Back 

Office functions. 

 

 
 

Also note that the resize button will appear for all types of reports when they’ve been run via a Back Office Shortcut. 

The below example shows various Report Types that have all been run via a Back Office Shortcut, all resized and 

displayed concurrently. 
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Stock Items 

IP-1595 – Stock Items Grid Screen – MDI Functionality [beta] 

This function adds MDI (Multiple Document Interface) functionality to the Stock Items Grid screen. 

This means it is now possible to resize the Stock Items Grid screen on screen resolutions larger than 1024x768.  

Resizing the Stock Items grid makes it possible to access other Idealpos Back Office functions whilst the Stock Items 

Grid screen is open. 

Note that a lower screen resolution of 1024x768 does not support this function due to the lack of available screen 

resolution real-estate. 

Also note that when the Modify Stock Item window is displayed, it will appear in full-screen mode.  

Other Idealpos menus/functions cannot be accessed while the Modify Stock Item window is open. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

The top-right corner of the Stock Items grid screen will now display a maximise/restore button which can be used to 

toggle the Stock Items grid between full screen and windowed mode.  

Note that this button will not appear on lower resolution screens such as 1024x768; a resolution greater than 

1024x768 is required.  

Some examples of screen resolutions which support the resize function include:  

 

• 1280x720 

• 1280x768 

• 1366x768 

• 1440x900 

• 1920x1080 

• 3840x2160 
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When the Stock Items grid screen has been resized to a window, other functions in Idealpos via the Back Office 

Dashboard/menu can now be accessed, whilst also showing the Stock Items grid.  

 

 
 

The Stock Items grid can also be dragged to the desired position on the screen by clicking anywhere within the title 

bar area of the window and dragging to the desired position. 

The area that represents the title bar has been illustrated in the example below; click anywhere in the area shown and 

drag the window to the desired position on the screen. 
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As mentioned previously, the Modify Stock Item window will still be displayed in full-screen mode. 

When modifying a Stock Item, access to other Idealpos Back Office functions are unavailable. 

 

 
 

When the main Stock Items grid window is being displayed in windowed mode, Idealpos can be minimised which will 

trigger both the Idealpos Back Office Dashboard and the Stock Items grid to minimise to the Windows Taskbar. 
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Idealpos and the Stock Items grid is now minimised to the Windows Taskbar. 

 

 
 

Clicking on the Idealpos icon on the Windows Taskbar will restore Idealpos and the Stock Items grid to its previous 

position. 
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IP-5130 – Stock Item Search – UI more intuitive 

This function enhances the search function in the Stock Item window by making the User Interface more intuitive.  

 

The following changes have been implemented: 

Magnifying glass icon included in the search field (to indicate that it is a search field). 

The currently selected Search Type (e.g. Code, Description, Description 2, etc.) has been moved from within the search 

field (which was previously only displayed in feint grey and only visible prior to entering a search term) to above the 

Search field (the currently active Search Type is always visible and more prominent than it was previously). 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

The Search Type function is available on the top-left corner of the Stock Items window. 
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The search field now contains a magnifying glass icon within the search field to indicate that it can be used to search. 

 

 
 

The currently selected Search Type is displayed above the Search field. 

 

 
 

Clicking on the Search Type text (e.g. Code, Description, etc.) will display the Search Type list, which can be used to 

change the Search Type. 
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Most Search Types will display a search field below, but some will require additional selections which will appear at the 

top of the Stock Items grid. 

Examples of each Search Type are shown below: 

 

       
 

Selecting ‘Price Changes’ will display two dropdown boxes at the top of the Stock Items grid which can be used to 

filter the results by the Price Changes.  

The first dropdown box at the top enables the selection of the Price Level. 

The second dropdown box enables the selection of the date/time since the Price Changes occurred. 

 

 
 

Selecting ‘Attribute’ will display two dropdown boxes at the top of the Stock Items grid which can be used to filter the 

results by Attribute. 

The first dropdown box at the top enables the selection of the Attribute Type (e.g. Container Type, Country of Origin). 

The second dropdown box at the top enables the selection of the Attribute (e.g. 1.25L Bottle, 2L Bottle, Australia, Italy).  
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The selected Search Type is displayed above the search field. 

 

 
 

Enter a search term into the field.  

The Stock Items grid will be filtered and display any Stock Items that match the search term that was entered. 
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Stock Manage/Pocket Stock 

IP-5228 – Create Separate Purchase Orders from Pocket Stock Data 

This function adds the ability to create separate Purchase Orders from Pocket Stock data. 

In venues such as convenience stores or small grocery stores, Stock Manage/Pocket Stock can be used as a tool to 

create a Purchase Order for any items that are low in stock or no stock remaining on the shelf. 

Where any shelves are identified that contain minimal stock (or no stock levels), the Stock Item’s Scan Code (or shelf 

label containing the Stock Item Scan Code) can be scanned into a Stock Receive batch in the Stock Receive module of 

the Stock Manage/Pocket Stock app. 

Once all the identified items have been scanned, the Stock Receive can be saved and then uploaded to Idealpos. 

In Idealpos when clicking on the Stock Mange > Stock Received option, the Stock Receive batch will contain a new 

button ‘Create Purchase Orders’ – this button will only be visible for Stock Received batches that do not contain an 

Invoice number and do not contain a Supplier code in the Receive batch. 

Pressing the ‘Create Purchase Orders’ button will trigger Idealpos to create one or more Purchase Order(s) for each 

Supplier that contains Stock Items in this Stock Receive and the items will be added to their respective Default 

Supplier’s Purchase Order. 

Once complete, the Stock Receive batch will be cleared from the Idealpos > Stock manage > Process Stock Received 

menu. 

If there are any items in the Stock Receive batch which do not have a default Supplier, the Stock Receive batch will 

remain and will only contain the Stock Items that do not have a default Supplier. Those items will need to be manually 

modified and a Supplier assigned to them so that the process can be repeated to create Purchase Orders for those 

remaining items. 

 

This function will save time, removing the need to create a separate Purchase Order for each Supplier and adding 

those Supplier’s items to the order. 
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To use this function, go to: Stock Manage or Pocket Stock. 

Ensure that you have the latest data on the device.  

If the latest data from Idealpos is required in the app, click on:  

Data Control > Download/Replace existing Data > Download. 

 

 
 

 
 

Go to: Stock Receive > +. 
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Enter a Reference into the Details field and press ‘Save’. 

This step ensures that a batch is created on the device and that any scanned items will be retained within the batch 

after pressing the ‘Save’ button later. 

 

 
 

The app will return to the list of Stock Receive batches. 

The newly created batch will appear as a blank entry. 

Select the entry from the list. 
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Scan an item or press the ‘+’ button to search for a Stock Item. 

 

 
 

Enter a Stock Item description and select the required item. 
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Enter the Quantity that is required in the Purchase Order and if required, modify the Cost as required > Save. 

The Cost displayed will be the current cost that was retrieved from Idealpos when the data was Downloaded in the 

initial step outlined further above.  
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Repeat the process as required for all items that need to be ordered. 

Once the items have been entered into the app, press the ‘Save’ button at the bottom of the main Stock Receive 

screen. 

The below screenshot contains items ordered from 3 different suppliers. 

 

Coca Cola – Coke 2L, Fanta 2L, Sprite 2L. 

Campbells Cash & Carry – Cadbury Family Block, Cadbury Turkish Delight, Cadbury Mint Block. 

Bidvest – Lime Juice 2L, Orange Juice 2L, Apple Juice 2L. 
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From the main Pocket Stock/Stock Manage menu, select Data Control > Upload. 
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The Idealpos Back Office Dashboard will display a ‘Stock Manage Data Available’ prompt. 

 

 
 

Go to: Idealpos Back Office > Stock Manage > Process Stock Received. 

 

 
 

The Process Stock Received window is displayed. 

If the Stock Manage/Pocket Stock data contained other Stock Receive batches, ensure that the blank Invoice option is 

selected. When a Stock Receive with a blank Invoice is uploaded and selected from the Invoice list [in the Process 

Stock Received window], a ‘Create Purchase Orders’ button is displayed on the top-left corner of the window. 

Pressing this button will trigger Idealpos to create a Purchase Order for each Supplier that contains Stock Items in this 

Stock Receive and the items will be added to their respective Default Supplier’s Purchase Order. 
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After pressing the ‘Create Purchase Orders’ button, a confirmation prompt is displayed. 

Press ‘Yes’ to continue. 

 

 
 

The Stock Receive batch will be cleared from the Idealpos Stock Manage menu. 

Go to: Back Office > Transactions > Stock Control > Stock Purchases. 

 

A Purchase Order has been created for each Supplier that contained Stock Items from the resulting Stock Receive. 
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The Stock Items within each Purchase Order are shown as follows: 

 

 
 

 
  



 Update History 
Return to top 

Idealpos 8 Build 10 - Update History Page 59 of 63 
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If a Stock Receive contains Stock Items which do not have a Default Supplier, the Stock Receive batch will not be 

cleared from Idealpos > Stock Manage > Process Stock Receive. 

Only the remaining Stock Items which do not have a Default Supplier will be displayed. 

To demonstrate this, the Default Supplier and Supplier Code were cleared from the Stock Item ‘Apple Juice 2L’ via File 

> Stock Control > Stock Items. 

After Creating Purchase Orders for a Stock Receive batch that contains one or more items without a Default Supplier, 

the Process Stock Received window will only contain the remaining item(s). 
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To create Purchase Orders for those items, each Stock Item will need to be manually modified via File > Stock Control 

> Stock Items and a Default Supplier will need to be assigned to each item. 

 

 
 

After selecting the Default Supplier and entering the Default Supplier Stock Code, press the ‘Save’ button. 
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Once a Default Supplier has been assigned to the remaining items, Purchase Orders can be created for those 

remaining items by going to: Back Office > Stock Manage > Process Stock Received > Create Purchase Orders. 

 

 
 

New Purchase Order(s) will be created for the item(s). 
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Zebra Labels 

IP-5213 – Zebra Kitchen Labels – Support for Date/Time 

This function adds support for Date/Time to Zebra Kitchen Labels. 

When a Zebra Kitchen Label Printer prints out an order, it will now contain the Date/Time (the same as what appears 

on a standard Kitchen Docket Print). 

This function is hard-coded and cannot be toggled. 

For further details about configuring and using Zebra Kitchen Labels, click here to view the Zebra Label support for 

Kitchen Printers topic in the Idealpos User Guide. 

 

https://userguide.idealpos.com.au/Default.htm#Labels/Zebra%20Label%20support%20for%20Kitchen%20Printers.htm

