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EFTPOS 

IP-4853 – Quest EFTPOS: Ability to turn off receipt printing 

This function adds the ability to turn off receipt printing for the Quest EFTPOS Integration. 

When this option is enabled in the POS Terminal EFTPOS Settings (Don’t automatically print EFTPOS Receipt when 

Receipts turned off), the EFTPOS receipt will not print automatically after paying for a sale using the Quest EFTPOS 

integration. If the customer requires an EFTPOS receipt, the Receipt button can be pressed, which will print the 

customer’s receipt, including the EFTPOS receipt. 

 

To configure this function, go to: 

Back Office > Setup > POS Terminals > Select Terminal > Modify. 

Within the EFTPOS Settings tab, enable the checkbox: 

“Don’t automatically print EFTPOS Receipt when Receipts turned off” 
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When disabling the automatic printing of EFTPOS receipts, ensure that you have a Receipt button on your POS Screen 

so that if the customer requests a receipt, the button can be pressed to issue them with a receipt. 

You will also want to ensure that you have a Receipt On/Off button to toggle the auto printing of receipts. 

If you already have a Receipt button and Receipt On/Off button, you can skip this step. 

 

Go to: Back Office > Setup > POS Screen > POS Screen Setup 

Select a POS Screen Layout > Buttons. 

This step involves the creation of two POS Screen buttons. 

 

For the standard “Print Receipt” button, it is recommended to have this button towards the top of the POS Screen 

layout so that it is always visible, regardless of which POS Screen tab is currently being displayed. 

 

For the Receipt On/Off button, we recommend placing this button on a Manager or Admin tab, to prevent staff from 

accidentally pressing the button. You may also want to have it on a Manager or Admin tab so that you can control 

which staff have access to the tab, to prevent unauthorised staff from toggling the receipt on/off. 

 

Configure the button for printing receipts as follows (you may want to configure this button towards the top of the 

POS Screen Grid, to ensure that it is easily accessible, regardless of the POS Screen tab being displayed on the POS 

Screen): 

 

  
 

Configure the button for toggling receipts On/Off as follows (when using the POS Screen, the text displayed on the 

button will indicate whether Receipts are On or Off, and pressing the button will toggle the receipt printing to On or 

Off, as shown below). 
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Interfaces 

IP-3654 – Pay@Table Interface – Support for Promotions/Surcharges on Handheld Orders 

This function adds the ability for Idealpos to support Promotions and Surcharges for Items that are saved to a Table 

via Handheld/Pocket Pad. Promotions/Surcharges will not appear in the app at the time the order is being saved to a 

table, however, Surcharges/Promotions will appear when performing an enquiry on a Table via the app and/or 

Idealpos. Promotions/Surcharges will also be displayed and applied when paying the items on the table. 

 

To enable this function, go to: Back Office > Setup > Global Options > Interfaces > Pay@Table 

 

Configure the following settings: 

 

• Enable the checkbox “Handheld Orders calculate Surcharges/Promos”. 

 

• Tender - Select a Pay@Table Tender – This step is required – if the Tender is set to “No Tender Type”, this 

“Handheld Orders calculate Surcharges/Promos” function will not work.  

If required, you can modify the description of an unused Tender by going to Back Office > Setup > Function 

Descriptors > Select an unused Tender and modify the Description to Pay@Table.  

Note that the Tender which is selected does not need to be enabled on the POS Tender Screen – it is simply 

required to enable the “Handheld Orders calculate Surcharges/Promos” function. 

 

• POS Master – Enter the terminal number of your main POS Terminal which runs POSServer. 

 

After configuring this function, you must open IPS Utils and perform a Close 

Suite/Open Suite for the change to be applied. Closing/Opening Idealpos is not 

sufficient and will cause issues if you miss this step. 
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Once the settings have been configured and the Idealpos Close Suite/Open Suite has been performed, you may add 

items to an order via the Handheld/Pocket Pad app. 

If those items are part of a Promotion (e.g. 2x Flat White in the Idealpos Demo Database) or if there is a Surcharge 

configured via Back Office > File > Sales > Surcharges, the Promo/Surcharge will be applied to the items at the time 

the items are being paid for via the Idealpos Table Map. 

 

Send items from the app 
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In Idealpos, go to: POS Screen > Table Map. 

Select the Table which the order was sent to, then press the “Details” button. 

Any Promotions/Surcharges will be displayed. 
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Selecting the table from the Table Map and pressing the “Pay All” button will also apply the Promo/Surcharge and 

display them on the POS Screen. 

 

 
 

Any Promotions and/or Surcharges will be displayed and applied to the sale. 
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Kiosk 

IP-4868 – Kiosk Module – Support for looping images/movies on Home Screen 

This function adds the ability to display looping images/movies on the Kiosk Home Screen. 

When Idealpos is first started on a Kiosk, the Home Screen Image will be displayed, then after a short timeout, 

Idealpos will begin looping through any image/video files that are stored within a pre-configured folder location. 

When a consumer uses the Kiosk by pressing the screen, the image/video that is currently being displayed will 

disappear and they will be presented with the standard Kiosk screen layout so that they can add their desired items. 

After the consumer has completed their order and payment, the Kiosk screen will again return to display the looping 

images/videos, ready for the next consumer. 

 

To configure and use this function, go to: Setup > POS Terminals > Select Kiosk Terminal > Modify. 

Within the Display/Kiosk tab, go to “Home Screen Images Location” and specify the folder location that contains the 

images/videos that you want to display on the Kiosk Home Screen. 

The folder containing the Home Screen Images should be created within this location “C:\ProgramData\Idealpos 

Solutions\Idealpos\Pictures\”  

 

Note that if the Home Screen Images Location field is blank, Idealpos Kiosk will simply display the static image that has 

been configured in the Home Screen Image field. 
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An example of a Home Screen Images Location is shown below: 

 

 
 

A mix of images and/or video files can be copied into the Home Screen Images Location configured above. 

Supported file types include: 

 

• .JPG 

• .BMP 

• .WMV 

• .AVI 

• .MOV 

• .MP4 
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To adjust the number of seconds between each image, go to:  
Back Office > Setup > Global Options > Other Options > Home Screen > Seconds between images 
 
Also note that the “Slideshow Start Time” field will determine the number of seconds Idealpos will wait between 
displaying the initial “Home Screen Image” and the images/videos that are stored in the Home Screen Images 
Location. 
 

 
 
After the config changes have been made to the POS Terminals/Global Options, close the Global Options window 
and restart the Kiosk. 
After the Kiosk is started, the Home Screen Image will be displayed first, then after the number of seconds 
configured in the “Slideshow Start Time” (configured in Global Options above) have lapsed, Idealpos will then display 
the images/videos in the Home Screen Images Location folder configured in POS Terminal Settings. 
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Kitchen Dockets 

IP-4856 – Yes/No Option to Print Bar Tab Customer name on Kitchen Prints 

This function adds the ability to print the Bar Tab Customer name on Kitchen Dockets via a Yes/No Option. 

The Customer Name that has been entered into the Bar Tab Customer record will be printed to the Kitchen Docket 

when this Yes/No Option is enabled, and an Item is saved to the Bar Tab. 

 

To configure and use this function, go to: Back Office > Setup > Yes/No Options 

Enter “Customer Name” into the Search field, then enable “Bar Tabs – Print Customer Name on Kitchen Prints”. 

 

 
 

Close the Yes/No Options to save your change. 

 

Go to: Back Office > File > Customers > Customers. 

Select “Bar Tabs” on the bottom-left corner of the window to filter the window by Bar Tab Customers. 

Press “Add” to add a new Bar Tab Customer, or modify an existing Bar Tab Customer by selecting a Customer and 

pressing the “Modify” button. 

 

 



 Update History 
Return to top 

Idealpos 8 Build 7 - Update History Page 12 of 25 

 

When creating/modifying a Bar Tab Customer, ensure that the following Fields/Settings have been 

configured/entered: 

 

Last Name/Given Names: Enter the Customer’s name. 

Customer Type: Select “BAR TABS” 

Bar Tab checkbox: Ensure that this checkbox is enabled 

 

Press the “Save” button on the top-left corner of the window to save your changes. 
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Go to: POS Screen > Bar Tab 

 

 
 

Select the Bar Tab containing the Customer’s Name. 
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Add Items to the Bar Tab, then press “ENTER”. 

 

 
 

The Kitchen Docket will be printed to the Bar Printer containing the Stock Items that were ordered as well as the 

Customer’s Name, as shown in the example below: 
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Range Programming 

IP-4923 – Stock Item Range Programming – Support for Modifier Grids field 

This function adds the ability to perform Range Programming on the Modifier Grids field (which is 

configured/displayed in the Advanced tab of a Stock Item). 

The Modifier Grids field was formerly known as the “Grid Link” or “Link to Grid” field and is used for configuring the 

POS Screen Grid(s) that are displayed when the Stock Item is added to a sale. 

 

Before accessing the Range Programming function, you will need to take note of the Codes for the POS Screen Grids 

that you want to apply to your Stock Items. 

 

Go to: Back Office > Setup > POS Screen > Grids. 

The Code(s) which will be required for performing Range Programming on the Modifier Grids field are listed in the 

Code column, as shown in the example below: 
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To perform Range Programming on the Modifier Grids field, go to:  

Back Office > Utilities > Range Programming > Stock Items 

 

Specify the Stock Item Code, Description, Department or Supplier Range that you want to apply the change to. 

Leaving the selection fields at the top of the window as blank will result in the change being applied to all your Stock 

Items. 

 

Select “Modifier Grids” from one of the Fields and enter the Grids that you want to be displayed when the Item is 

added to a sale. Whichever order you enter the Modifier Grids is the order that they will be displayed when the Stock 

Item is added to a sale.  

 

 
 

Using the POS Screen Grid Codes from the screenshot on the previous page, if you want a Stock Item to display the 

Cook Types Meat Grid (Code 1), then the Small Drinks Grid (Code 71), you will need to enter 1,71 into the Modifier 

Grids field. 

 

E.g. 

 

 
 
Press the “Proceed” button on the top-left corner of the window to proceed with Range Programming. 
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Press “Yes” to confirm 

 

 
 

After Programming has been completed, a prompt will be displayed. Press “OK” to continue. 

 

 
 

Go to: Back Office > File > Stock Control > Stock Items. 

Modify any Stock Item that was included as part of the Range Programming process above, then click on the 

Advanced tab within the Stock Item. 

The Modifier Grids field will be populated with the POS Screen Grid Codes entered during Range Programming. 
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When the Stock Item is added to a sale in the POS Screen, the first Modifier Grid (Cook Types Meat) will be displayed. 
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After the minimum required number of items are selected from the first POS Screen Grid (Cook Types Meat as shown 

on the previous page), the second POS Screen Grid (Small Drinks) will be displayed. 
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After a Drink has been added to the sale, the POS Screen will return to the MAIN POS Screen Grid. 
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Room Interface  

IP-4880 – Support for Clarity Hospitality Room Interface 

This function adds the ability to configure Idealpos with the Clarity Hospitality Room Interface. 

In order to configure this interface, ensure that your Idealpos Licence Gateway has the “Clarity Hospitality” module 

enabled. 

Go to: Idealpos Back Office > Setup > Licence Gateway. 

Note that this is a paid module. Therefore, you will need to contact Idealpos or your Reseller and request for this 

module to be added to your licence. 

Once the module has been added to your licence, ensure that “Clarity Hospitality” appears within the Options column 

of each POS Terminal that will utilise this interface. 

You may need to press the “Reload” button in the Licence Gateway for the module to appear, then you may need to 

restart Idealpos for the module to be active. 

 

Go to: Back Office > Setup > Global Options > Interfaces > Rooms. 

Select “Clarity Hospitality” from the Interface Type. 

Configure the other options as required. 

Once configured, you may need to restart Idealpos for the changes to take effect. 

Note that you may also need to perform further configuration in the Clarity Hospitality software. 

Refer to Clarity Hospitality for further assistance with any configuration required within their system. 
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Stock Transfers 

IP-4852 – Stock Transfers – Ability to Copy from a previous Transfer 

This function adds the ability to Copy Stock Items from a previously processed Stock Transfer batch into the current 

Stock Transfer batch. If a set of Stock Items are frequently transferred between locations, this function can save time by 

allowing you to copy the Stock Items from a previously processed Stock Transfer batch into the current Stock Transfer 

batch. 

 

To use this function, go to: Back Office > Transactions > Stock Control > Stock Transfers 

Press the “Copy” button which appears towards the top-left corner of the window. 
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The “Copy Stock Transfer” window will be displayed with the following options: 

 

Period: Default option is Month to Date (options available include Today, Yesterday, Hour to Date, Week to Date, 

Month to Date, etc.). The period option will enable the filtering of Stock Transfers displayed that fall within the period 

that is selected. 

From/To: Select the From/To date to filter the transfers based on the date/time periods selected. The From/To fields 

are hidden when selecting “All Dates” from the dropdown box above. 

Reference: To filter the Stock Transfers by the reference, enter the Reference of the transfer and any Stock Transfers 

that match part or all of the entered value will be displayed. 

 

Override Source Location: Select a location to override the Source Location that was originally entered in the source 

transfer. If this dropdown box is left as blank/no selection, the original Source Location will be used. 

Override Destination Location: Select a location to override the Destination Location that was originally entered in the 

source transfer. If this dropdown box is left as blank/no selection, the original Destination Location will be used. 

 

The first list shown in the window contains a list of previously processed Stock Transfer batches. 

The second list shown in the window contains the individual Stock Items that were included in the Stock Transfer batch 

which is currently selected/highlighted above. 

 

Select the required Stock Transfer batch, then press the “Copy” button located on the top-right corner of the window. 
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After the Copy button is pressed, the “Copy Stock Transfer” window will close, and you will return to the Stock Transfer 

window, which will now contain all the Stock Items from the copied Stock Transfer batch. 

You can enter a Reference and Details for this Stock Transfer, then modify these Stock Items as required. 

To modify the Stock Items in the Stock Transfer, select a Stock Item and press “Modify” > Modify the 

Source/Destination and quantity being transferred. 

To delete any unrequired Stock Items from the Stock Transfer, select the item and press the “Delete” button on the 

left-hand side. 

Add additional Stock Items to the Stock Transfer batch by pressing the “Add” button on the left-hand side and adding 

the required items. 

Once you are happy with the Stock Items entered into the transfer and are ready to finalise the transfer, press the 

“Process” button on the bottom-right corner of the window. 
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IP-4883 – Stock Transfers Enquiry 

This function adds the ability to perform an enquiry on previously processed Stock Transfers. 

The Stock Transfer Enquiry function contains the ability to filter the Stock Transfers displayed based on the date/time 

and the Reference. 

Previously processed Stock Transferred will be displayed as two lists:  

- The first list will show a list of previously processed Stock Transfer batch names.  

- The second list will show the Stock Items that were transferred within the currently selected Stock Transfer 

batch name that was selected in the above list. 

 

To use this function, go to: Back Office > Enquiry > Stock Transfers 

 

At the top of the window, select the period to filter the Stock Transfers. 

If required, a Reference can be entered to display Stock Transfers that match the entered Reference. 

 

Select a Stock Transfer batch from the first list; the second list will update on-the-fly and display the Stock Items that 

were transferred in the selected Stock Transfer batch. 

Details displayed include the Stock Code, Description, Quantity transferred, Source Location and Destination Location. 

 

 
 


