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Build 45 

Update Details: 

** Enhancements 

    * [IP-472] - POS Grids - Force Selection with Minimum and Maximum options 

    * [IP-810] - Promotions Import supports POS/Location/Site/Customer Type/Price Level Headers 

    * [IP-1005] - Yes/No Option - Don't send Refunds to Kitchen Printers 

    * [IP-1011] - Stock Item Sales Report filtered by specific Refund Reason 

    * [IP-1035] - CAA Affinity Interface (Canada) 

    * [IP-1075] - Talkbox Voucher Integration 

    * [IP-1083] - Zebra Label support for Kitchen Print Items 

    * [IP-1090] - Deputy export: options to exclude RA accounts and to report on Ex-GST amounts 

    * [IP-1091] - Multiple Coupon Redemptions in a $ Discount Off Total Promotion 

    * [IP-1101] - Ability to search Customers using single quote character 

    * [IP-1139] - Permission for Adding Supplier Codes applied in Stock Purchases screen 

    * [IP-1148] - Improved speed for Supplier Enquiry - View Report 

    * [IP-1151] - Fast Add Stock Item - Warning if no Sell Price 

    * [IP-1165] - IBA Promotions Import - Exclude Batch option 
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Coupons 

Multiple Coupon Redemptions in a $ Discount Off Total Promotion 

This promotion is configured in such a way that if you redeem multiple discounted items within the one sale, and the 

coupon’s value is worth more than the total of those discounted items, they will all be discounted only up to the value 

of those items.  

 

Go to File > Sales > Promotions > Coupons > Add > Discount Type: $ Discount off Total > Select: Multiple 

Redemptions per Sale.  
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When coupons are redeemed for up to $60, only $45 worth of the coupons are within in the sale, so that is all that 

gets discounted.  

 

 
 

The remaining value on the coupon if not spent is not re-issued or redeemable in another sale.  
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Customers 

Ability to search Customers using single quote character 

In previous versions of Idealpos we did not recognize apostrophes in Customer names, such as O’Doyle and 

McDonald. This has now been remedied and can be used.  
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CAA Affinity Interface (Canada) 

This is a Customer Membership Interface. For more information please visit https://www.caa.ca/.  

 

You will need to have the CAA Licence in your Licence Gateway.  

 

Global Options 

Go to Setup > Global Options > Interfaces 2 > Customer Interface.  

 

Interface Type: CAA Affinity 

Username: Provided 

Password: Provided 

Location ID: Provided 

 

 
 

  

https://www.caa.ca/
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Promotions 

Go to File > Sales > Promotions > Add.  

 

 
 

Go to Advanced > User-Defined Text > [DONTAPPLYDISCOUNT].  
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Using POS with CAA 

Swipe the member card and CAA Member will display at the top of the screen.  

 

 
 

Enter the sale including any items and the Fuel to trigger the promotion.  
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Once you have finalized, the member number and CAA Dollar amount earned will be stamped into the sale and show 

on the Receipt. 

 

 
 

These details will be sent to the CAA Affinity Web Service in the background. If it fails for any reason other than 

internet connectivity, an error message will show. 

 

Once a successful send occurs, the background process will go and attempt to resend any failed messages in the 

queue. 
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Deputy Export 

Deputy export: options to exclude RA accounts and to report on Ex-GST amounts 

Deputy uses the sales data to work out the wage cost as a percentage of revenue. Most businesses work out wage cost 

targets as a percentage of net revenue. So, it is the net revenue (Ex-GST) amount that needs to be reported to Deputy. 

Gratuity figures are currently included in the sales data. This makes the reported wage percentage inaccurate 

(especially for venues that generate larger gratuities). The option to not export RA will include Gift Voucher sales. 

 

Two new options have been added when exporting to Deputy to allow you to select if these options get exported.  

 

Go to Setup > POS Terminals > Modify > Import/Export > Automatic Export Settings > Export Sales Format: Deputy.  
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IBA Interface 

IBA Promotions Import - Exclude Batch option 

A new option has been added to allow you to exclude a specific zone area when importing promotion files from IBA. 

You need to add the 3 characters that designates which zone you want to exclude.  

 

Go to Settings > POS Terminals > Import/Export > IBA Interface > Exclude Batch.  
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POS Screen Grids 

POS Grids - Force Selection with Minimum and Maximum options 

This feature allows you to configure the exact number of items the operator is expected to press before being allowed 

to move on.  

 

Go to Setup > POS Screen > Grids > Add.  

 

 
 

Go to the Grid list > Select your Grid in the list.   
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Press Items > Add all the required stock items in this grid, in this example, Ice Cream Flavours. It can also be used for 

Pizzas and Sandwiches where a maximum number of items are added for free.  

 

Touch Screen Grid Link – This function will only work on the last item selected on the grid. If you require the operator 

to go to another grid after selecting the last item, you need to add the grid link to all items as you cannot know which 

one it will be.  

Allow more than One selection of this button – This checkbox allows the operator to select multiple of a single 

item, if required. In the example of ice cream flavours, it’s especially so, however this might not always be the case.  

 

Items included in the grid can have a price allocated to them as per usual.  
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Link your Triple Ice Cream button to the Ice Cream Flavours Grid.  

 

 
 

On the POS Screen press the Triple Ice Cream button. The item will be charged and the Ice Cream Flavours grid will 

open.  
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The bottom of the grid will tell you how many items you need to select, in this example, 3. Once an item is selected 

(English Toffee), a count will display on the button as to how many of that flavour has been selected. The bottom of 

the grid will show how many items are yet to be selected.  

 

 
 

The second item will also show the count decreasing.  
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As soon as the last choice is selected the grid will exit to the main screen or touchscreen grid you selected for the item 

to go to. You cannot access the grid again unless you have it on the POS screen, or re-select the main item. If you 

make a mistake, void the sale and start again.  

 

 
 

You cannot add multiple quantities of the main item as it will not select the same quantities of the choices available. If 

multiple of the same item is required, you have to do them one at a time. 
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Printers 

Zebra Label support for Kitchen Printers 

This feature allows you to print a label which can placed on the product for the dispense to the correct customer. This 

will be beneficial mostly in fast food and convenience stores, where people order take-away that can take a few 

minutes to prepare. When you order a kebab, fish and chips or Chinese, your meals can have a sticker on them with 

the order details, so you can confirm that it is your order before you open it. The staff dispensing the meal to the 

customer might not be the one preparing it, so it allows for errors to be minimal.  

 

Setup Zebra Printer 

To be able to use this functionality, you will need to have a ZDesigner GC420d printer. The following label sizes have 

been configured to test with:  

• 56 x 46  

• 56 x 25  

• 40 x 28 

 

Once you have connected the printer, do a test print through Windows. You may need to calibrate the position of the 

information that gets printed to ensure all the information is visible.  
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Configure Idealpos Settings for Zebra Printer 

Go to Setup > Global Options > Printing > Kitchen Printer Names > ZEBRA LABELS.  

 

 
 

Go to Utilities > Range Programming > Stock Items > Select all required items to use Kitchen Printer ZEBRA LABELS. 

You can select individual items by going through File > Stock Control > Stock Items > Modify.  
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Go to Setup > POS Terminals > Modify > Kitchen Printers > Kitchen Printer: ZEBRA LABELS > Zebra Labels: ZDesigner 

GC420d.  
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Using Zebra Labels for Kitchen 

In Idealpos, sell an item that will print a label. A label will be printed with all the details that are included in the sale.  
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Promotions 

Promotions Import supports POS/Location/Site/Customer Type/Price Level Headers 

The new import fields need to be specified in the Header. They can be: 

CUSTOMER_TYPE, CUSTOMERTYPE, CUSTOMERTYPERANGE, CUSTOMER_TYPE_RANGE, POS, POS_NUMBER, 

TERMINAL, POS_RANGE, LOCATION, LOCATION_RANGE, SITE, SITE_RANGE, PRICE_LEVEL 

 

As the POS Range, Location Range, Site Range, Price Level all share the same field, whichever field comes first will take 

precedence if you have a record that has data in both fields. 

 

Please note: any fields with commas will need to have double quotes around them: 

ie 1-10,15 will need to be "1-10,15" 
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Refunds 

Stock Item Sales Report filtered by specific Refund Reason 

Large retail venues can process a lot of refunds and need to be able to see a pattern of product returns to act quickly 

to remove those items from sale in the event of a larger issue.  

 

Go to Reports > Sales > Stock Item Sales > Optional Grouping: Refund Reason (untick Totals Only) > Selection Range 

> Refund Reason.  
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TalkBox Voucher Integration 
TalkBox is an online communication service for marketing to your customers by Impact Data. For more information, 

please visit https://www.impactdata.com.au/talkbox.html.  

 

The TalkBox app 

• It allows the creation of compelling campaigns simply made, with our powerful editing tool that’s as 

straightforward as drag and drop 

• Whether you use one channel or a sequence of email, SMS, social and web; TalkBox helps you connect to your 

audience 

• The true power of TalkBox is realised with our automated communications that drive your business without 

you lifting a finger, delivering time back to you 

• A well-structured journey to welcome, win back or build customer spend or a data driven branching path, is 

the key that drives increased value for your business 

• The integration of Net Promoter Score to create a customer feedback channel is powerful but when 

combined with Enlight your customer feedback is related to observational data such as weather conditions to 

highlight operational improvement opportunities  

• Our reporting drives understanding of engagement and return on investment.  

 

TalkBox Settings 

You will need to sign up to the application before you can log in. Once you have access, go to 

https://talkbox.impactapp.com.au/users/sign_in and log in with your details.  

 

 

https://www.impactdata.com.au/talkbox.html
https://talkbox.impactapp.com.au/users/sign_in
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Once you have logged in, go to Tools > Vouchers.  
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Select New Voucher from the menu and fill out all fields that you want to use. When you have finished, select Create 

Voucher.  

 

 
 

The voucher will be added to your list of vouchers, either past or present.  
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Idealpos Settings for TalkBox 

Go to File > Sales > Promotions > Coupons > Add > Description: Must be the same as TalkBox and is case-sensitive.  

 

  
 

Go to Advanced tab > User-Defined Text: [TALKBOX].  
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Send a TalkBox Coupon 

Once you have created your coupon voucher in TalkBox and Idealpos, you need to send it out.  

 

Go to TalkBox > Communicate > Select how you want to send the voucher.  

 

 
 

Build your communication using one of the provided templates, or create your own.  

 

 
 

When you are happy with the result, select to Preview and Continue.  
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View your email campaign in different device previews and press continue when you are happy.  
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Select which recipients will get your communication and select Continue.  
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Select the time you want to send the communication, either Now, or choose the time in the future. Press continue 

once you are ready.  

 

 
 

Confirm the details are correct and press Confirm to send.  
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Select Launch It when you want to send.  

 

 
 

The communication will be configured and sent.  

 

 
 

Once sent, the details will display to show you the results.  

 

 
 

  



 Update History 
 

Redeem a TalkBox Coupon 

The customer will receive their voucher.  

 

 
 

Enter a redeemable item into the sale and scan the voucher. The item will be discounted and voucher redeemed 
almost instantly. 
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You can then go to TalkBox and check the reports on the redemptions.  
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Users 

Permission for Adding Supplier Codes applied in Stock Purchases screen 

The File > Stock Control > Stock Items > Supplier Codes User Permission is now being applied to Stock Purchases - 

when you browse Supplier Stock Codes it hides the "New" button. 
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Yes/No Options 

Don’t send Refunds to Kitchen Printers 

When using a Kitchen Monitor or whenever the kitchen just doesn’t need to know there has been a refund of a 

product, you can toggle this to happen.  

 

Go to Setup > Yes/No Options > Receipt/Kitchen > Don’t Send Refunds to Kitchen Printers.  

 

 
 

 


