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Idealpos 7.1 Build 1 

Update Details: 
** Enhancements 
    * [IP-208] - Floating Clerks - Ability for a timeout within active sales 
    * [IP-209] - Yes/No Option to inhibit returning to Home Screen after each sale 
    * [IP-1188] - Raffles inhibit redrawing of an already drawn number on multi-draw raffles. 
    * [IP-1312] - POS will report on mismatched Build Numbers on a network 
    * [IP-1511] - Pending sales - added Unit Price column 
    * [IP-2078] - Delete Customer Points when Customer Inactive for a Period 
    * [IP-2083] - Stock Level Enquiry Function for POS Screen 
    * [IP-2087] - Yes/No Option - Inhibit selling of items not Enabled in Location 
    * [IP-2156] - Added new Region setting for India 
    * [IP-2192] - Gaming - Combine Accounts into One Total excludes zero-value point buckets 
    * [IP-2195] - User Details Copy function 
    * [IP-2279] - First American Eftpos Integration 
    * [IP-2327] - Stock Transfer Reports - User Permission to Show/Hide Cost 
    * [IP-2341] - Customer Trial Balance - option to Force End of Last Month for Scheduling 
    * [IP-2346] - Westpac Group Eftpos - POS ID description setting for Pairing 
    * [IP-2353] - Centralized Customer Account/Layby Transactions retrieved from POSServer 
    * [IP-2356] - New Yes/No Option - Force Customer Entry On Coupon Redemptions 
    * [IP-2417] - Table Preview Show Seat Numbers 
    * [IP-2424] - Table Balance Amount shown on POS Screen 
    * [IP-2456] - Alternate Codes Modify/Delete User Permissions 
    * [IP-2477] - "Show Rates next to items on Receipt" option applies to A4 Invoice 
    * [IP-2485] - Stock Item Sales Report - Group by Sale Type 
    * [IP-2486] - Stock Item Attribute to Remove Tax on Take-Away Items (Canada/USA) 
    * [IP-2487] - Option to Show/Hide Customer Phone/Email on Coupons 
    * [IP-2494] - Increased Limit of number of Standard Promotions allowed 
    * [IP-2503] - Improved speed for generating Stock Movement Reports 
    * [IP-2516] - Yes/No Option - Warn when selling Items not enabled in Location 
    * [IP-2520] - Site Management - filtering Site Items by Scan Code in Stock screen will display Base Item's Scan 
Code 
    * [IP-2533] - Price Enquiry Function allows Selling of Item  
    * [IP-2542] - Layby Descriptor programmable through Function Descriptors 
    * [IP-2543] - Layby Functions separated from Account Functions 
    * [IP-2551] - Dashboard - support for 3d Large Pie Chart 
    * [IP-2574] - Basic Kiosk Functionality 
    * [IP-2579] - Yes/No Option - Hide Alert Level Warnings 
    * [IP-2593] - Cash Discount Function 
    * [IP-2617] - Clerk Buttons can change Clerk for single Sale Line 
    * [IP-2621] - Alpha-Numeric Tables - support for Ideal Kitchen Monitor 
    * [IP-2623] - Chinese character support in Stock Manage data uploads 
    * [IP-2631] - New Login Screen 
    * [IP-2643] - Larger font for Customer Name on Customer Display 
    * [IP-2653] - Stock Transfers to Different Items - option to Update Cost based on Source Item 
    * [IP-2658] - User Permission to Hide Stock Item Sales button on Journal Enquiry function from POS 
    * [IP-2662] - Send Unprocessed Purchase Orders to Stock Item Labels 
    * [IP-2668] - POS Button Captions can include Carriage Returns 
    * [IP-2672] - Ability To Sort Purchase Order By Supplier Code 
    * [IP-2675] - Wildcard Search Stock Notes as Long Item Descriptions 
    * [IP-2689] - DOB2 Tag for Stock Item Sales Prompt can handle Specific Date 
    * [IP-2693] - USA/Canada - Remove Tax based on Customer Type 
    * [IP-2698] - Gratuity % Functionality 
    * [IP-2708] - Stock Item Sales Report - Group by Audit 
    * [IP-2709] - Stock Item Sales Report - Clerk Selection Range 
    * [IP-2726] - SmartConnect EFTPOS - support for Asynchronous Communications 
    * [IP-2729] - Canada - "Donut Tax" removes all Tax Rates 
    * [IP-2734] - Pending Sales report - Includes Total by Sale Type Status 
    * [IP-2745] - Packet Filtering - Tables option includes Pending Sales packets 
    * [IP-2752] - MYOB AccountRight - Override IP setting for Desktop Connection 



    * [IP-2754] - MAXTRIPS tag for Multi-Trip Promotions 
    * [IP-2764] - POS Description shows on the Reports header 

 

Windows POS Ready 2009 not supported 

Please note that Idealpos 7.1 is not supported on Windows POS Ready 2009 systems. Attempting to install it on such 

systems will result in a non-working installation of Idealpos. 

 

The version of Windows installed on a system can be checked by going to:  

Start > Run > Enter “winver” into the run window, then press “OK”. 

 

 
 

A window will appear and will show the version of Windows that is currently installed on the terminal. 

If you see Windows Embedded POSReady 2009, DO NOT INSTALL IDEALPOS 7.1 ON THE TERMINAL 

You will need to upgrade to a newer version of Windows before installing Idealpos 7.1. 
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Accounting Interface 

MYOB AccountRight Live – Override IP setting for Desktop Connection 

This function adds the ability to specify the IP address of the PC which the MYOB AccountRight Live application is 

installed on when using a Database Location of “Desktop”.  

This function can be used when the MYOB AccountRight Live application is installed on a system different to the one 

where Idealpos is installed. When the Override IP field is blank, Idealpos will connect to the MYOB AccountRight Live 

installation on the local PC. When an IP address is entered into the Override IP field, Idealpos will connect to the MYOB 

AccountRight Live installation located on the remote PC.  

 

To use this function, go to: Setup > Global Options > Accounting 

Ensure that the Accounting Package is set to “MYOB AccountRight Live” and the Database Location is set to Desktop 

The Override IP option will be displayed.  

Enter the IP address of the system where MYOB AccountRight Live is installed on.  

Also ensure that you enter your Company Name, User Name, Password and Resent to Accounting Password.  

Finally, press the “Get Accounts” button to retrieve your accounts from MYOB. 

 

The below example shows an Override IP of 192.168.1.1, a User Name of Administrator and blank Passwords. 

Ensure that you substitute the details that are relevant to your system configuration. 

 

  



Back Office 

POS will report on mismatched Build Numbers on a network 

This function adds the ability for Idealpos to display a prompt which will report when there are mismatched Build 

Numbers of Idealpos running on a network. 

There is no configuration required to enable this feature and the prompt will be displayed automatically in the event 

that Idealpos detects mismatched Build Numbers running on other terminals configured in Setup > POS Terminals and 

Setup > Networking. The prompt can also be displayed manually by going to Setup > POS Terminals > Versions 

 

The prompt will only be displayed when the following conditions occur: 

• Prompt displayed on systems which are licenced for Back Office and detect other Idealpos systems running 

mismatched build numbers. 

• Prompt will be displayed 10 minutes after starting Idealpos and detecting a mismatched build number 

• Once the prompt has appeared and the user has closed the prompt, it will not be displayed again unless 

Idealpos is restarted 

 

The versions prompt displayed will appear as below and the version numbers displayed in the prompt will be reflective 

of the versions that were detected: 
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To view the prompt manually, go to Setup > POS Terminals > Versions 

 

  
 

After pressing the “Versions” button, the Versions window will appear as per the example displayed further above.  



Dashboard – Support for 3D Large Pie Chart 

This function adds the ability to view the Pie Chart that is displayed on the Idealpos Back Office screen as a large 3D 

Pie Chart. When viewing the graph as a 3D Pie Chart, the chart can dragged/spun around. In addition, when using a 

mouse with a scroll-wheel, the size of the 3D Pie Chart can be increased/decreased. 

This 3D Pie Chart functionality may assist with viewing and representing the data from different perspectives.  

In order to view the Pie Chart, the terminal needs to be licenced for Back Office and the Yes/No Option “Show 

Dashboard” must be enabled for the terminal. 

 

To use this function, go to: Idealpos Back Office screen > Click on the Pie Chart 

Click on the Pie Chart as outlined in orange in the below example. 
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After clicking on the Pie Chart, an enlarged version of the Pie Chart will be displayed. 

Note that the enlarged chart might be displayed in 2D view as per the below example: 

 

 
 

To display the chart in 3D view, hover anywhere over the Pie Chart with the mouse cursor, click and drag the mouse. 

The chart will move and will be displayed as a 3D chart. You can continue to hold down the mouse button and drag to 

position the chart as desired. 

 

 
 

  



You can also increase/decrease the size of the enlarged chart by hovering the mouse cursor over the chart and 

scrolling up/down using the mouse scroll-wheel. The 3D chart will increase/decrease in size. 

 

 
 

The chart will be updated on-the-fly when using the selection options below the chart. Options available for selection 

are the type of data being displayed (Sites, Locations, Sales Categories, Hours, Departments, POS Terminals or 

Tenders), Period (Financial Year, This Year, Last Year, Month) as well as the colour of the chart. These selections can be 

made using the options outlined in orange in the below example: 

 

 
Once you have finished viewing the enlarged chart/3D Pie Chart, close it using the “X” button displayed towards the 

top-right corner of the Pie Chart graph. 
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Clerks 

Clerk Buttons can change Clerk for single Sale Line 

This function adds the ability to change the Clerk for a single line in a sale. 

This may be useful in venues where multiple Clerks process a single sale and there is a need to go back and change 

the Clerk who was either responsible for adding or preparing the item that was added to the sale.  

 

In order to use this function, POS Screen buttons for each Clerk need to be created.  

The following Yes/No Options must also be disabled: 

• Each sale applies to one Clerk only 

• Overlapping Clerks 

 

To configure and use this function, follow the below steps: 

Go to: Setup > Yes/No Options > Clerks 

Disable the following options: 

• 10. Each sale applies to one Clerk only 

• 19. Overlapping Clerks 

 

 
 

  



In order to use this function, buttons for the required Clerks will need to be created on the POS screen. 

 

Go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

Either find and click on a blank tab at the bottom of the POS screen, or select an existing POS screen tab to create the 

Clerk buttons. 

In this example, we will use the RETAIL tab to create the Clerk buttons. 

Click on a blank POS screen button, then use the Clerk function to specify the Clerk. 

The below shows the Clerk function being used to select the Clerk named “Alex” 

 

 
 

Repeat the above process to create POS screen buttons for each required Clerk. 
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Once completed, you should then see a POS screen button for each Clerk. 

The below example shows Clerk buttons created towards the right-hand side of the POS screen. 

 

 
 

Close the POS screen layout to save changes. 

 

  



Then go to the POS screen by pressing the POS button from the main Idealpos Back Office dashboard. 

Add items to the sale as required. 

The currently logged on Clerk is displayed on the top-left corner of the POS screen 
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To view the Clerk which added an item to the sale, click on the individual item and the Clerk name will appear at the 

top of the POS screen in the centre. The below example shows the “BIG BREAKFAST” Stock Item selected in the Sale, 

with the Clerk name of “Alex” shown in the middle of the POS screen.  

This indicates that Alex was the Clerk that added the selected Stock Item to the sale. 

 

 
 

  



To change the Clerk that added the selected item, click on the POS screen tab which contains the Clerk buttons that 

were added earlier, then click on the Clerk button for the selected Stock Item. The Clerk name will be updated for the 

selected Stock Item and the new Clerk name will be displayed in the middle of the POS screen. 

The below example shows the “BIG BREAKFAST” Stock Item which has been changed to the Clerk “Bjorn” using the 

Clerk button “Bjorn”. This is indicated by the Clerk name displayed in the middle of the POS screen. 

 

 
 

You may repeat the above process for each Stock Item in the sale until all Stock Items have been changed to the 

required Clerk. 

The sale can be finalised by pressing the ENTER button, then select the amount/tender type. 
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Note that the printed receipt will display the Clerk which was logged into the POS at the time the sale was finalised. 

However, each Stock Item that was changed to a particular Clerk will be recorded accordingly in Idealpos reports as 

well as the Journal History Enquiry. 

This can be confirmed by going to: Enquiry > Journal History > Select the transaction from the left > Transaction 

details are displayed on the right, including each item that was changed to another Clerk. 

 

  
 

  



This can also be reported using reports such as the Stock Item Sales Report. 

Go to: Reports > Sales > Stock Item Sales 

Group by Clerk then press “View” 

 

 
 

The Stock Item Sales Report will be broken down by Clerk, showing the Stock Items that each Clerk added to the Sale. 
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Floating Clerks – Ability for a timeout within active sales 

This function adds the ability to have a Clerk Timeout apply within an active sale when using the Floating Clerks 

feature. When enabling the Floating Clerks checkbox next to the Clerk Timeout setting, the POS will automatically 

display the ENTER CLERK prompt after the Clerk Timeout period lapses, even if items have been added to the sale.  

This will then allow the Clerk to sign into another POS terminal and when they do, all the items that were added to the 

sale will automatically appear on any terminal they sign into. 

This function may be useful in butcher shops where the Clerk will frequently move between POS terminals in order to 

perform tasks such as weighing stock using a scale that may only be available from a specific POS terminal in the store.  

 

To use this function, the following options must be enabled:  

 

• POSServer must be enabled and running.  

For instructions on configuring the POSServer, refer to the POSServer topic in the User Guide. 

 

• Floating Clerks must be enabled in the POSServer (Go to: Setup > Global Options > Miscellaneous > Enable 

the Floating Clerks checkbox) 

 
 

• Compulsory Clerk must be enabled (Go to: Setup > Yes/No Options > Keyword Search: Compulsory > Enable 

Compulsory Clerk)

 
 

  

https://userguide.idealpos.com.au/#POSServer/POSServer.htm


Once the above options have been enabled, you will need to configure the Clerk Timeout Setting and enable the 

Floating Clerks checkbox next to Clerk Timeout. 

Go to: Setup > Global Options > General > Clerk Timeout/Floating Clerks 

 

Enter a value into the Clerk Timeout field in seconds that you’d like to use as a timeout value and enable the Floating 

Clerks checkbox. The below example shows a Clerk Timeout of 60 seconds (1 minute). 

 

 
 

Once the above steps have been completed, Idealpos will need to be restarted in order for the Timeout and Floating 

Clerk options to take effect. Ensure that Idealpos is restarted on all POS terminals for these settings to apply. 

Open IPSUtils (open the Windows Start Menu and search for IPSUtils), tick the option “Close IPS Utility” then press the 

“Close” button within the IPS Utility.  
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Once Idealpos has closed, you may start Idealpos and the changes will take effect. 

 

When the POS screen opens, the sale screen will show “ENTER CLERK”. 

Enter a Clerk ID and press ENTER. 

 

 
 

After signing in, the Clerk name will be displayed on the top-left corner. 

 

 
 

  



Add items to the sale as normal. 

 

 
 

After the timeout period lapses, the sale screen will return to the ENTER CLERK prompt. 

The Clerk can sign into any POS terminal by entering their Clerk ID and all the items will appear on the POS terminal. 

They can continue to add further items to the sale and if they walk away from the POS terminal, the Clerk Timeout 

period will lapse and they can then continue to sign into the next available POS terminal where they can add 

additional items to the sale. 

Once the Clerk is ready to finalise the sale, they can press the ENTER button to go to the Tender screen and select a 

Tender Type/Amount to finish the sale. 
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Coupon Promotions 

Option to Show/Hide Customer Phone/Email on Coupons 

This function adds an option to control whether a Customer’s Phone Number and Customer’s Email address is shown 

or hidden when printing Coupons. 

 

To use this function, go to:  

File > Sales > Promotions > Coupon Promotions > Select the Promotion from the list > Modify 

 

 
 

From the Coupon Promotion screen, select the Advanced tab. 

 

 
  



Within the Advanced tab, either tick or untick the “Show Customer Phone/Email on Coupon” 
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When the Coupon is triggered by the POS transaction, it will either print or hide the Customer Phone/Email on the 

Coupon, depending on how the above setting has been configured: 

 

Show Customer Phone/Email on Coupon disabled (unticked): 

 

 
 

Show Customer Phone/Email on Coupon enabled (ticked): 

 

  



Customers 

USA/Canada – Remove Tax based on Customer Type 

This function adds the ability to remove sales tax for Customers which are linked to a specific Customer Type. 

In the USA/Canada, some types of Customers are exempt from paying tax and this option allows those Customer 

Types to be exempt from tax. 

 

This function only applies to Idealpos systems that are configured for the Canada or USA region (Setup > POS 

Terminals > Modify > User Details > Region > Canada/USA) 

 

To configure this option, go to: File > Customers > Customer Types > Select the Customer Type > Modify 

 

Enter [REMOVETAX] into the User-Defined Text field as per the below example, then press the “Save” button on the 

bottom-right corner. 
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Go to File > Customers > Customers > Add 

 

Add a Customer and link them to the Customer Type which is exempt from tax as configured above.  

Press the “Save” button on the bottom-right corner to save the customer 

 

 
 

  



As a point of reference/comparison, create another Customer that is linked to a Customer Type not exempt from tax. 
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Go to the POS screen, add the Customer linked to the Customer Type exempt from tax, then add items to the sale 

which are applicable to tax. Finally, press the “Enter” button to go to the Tender screen. 

Tax will be exempt. 

 

 
 

  



As a comparison, adding the same items to the sale for aa Customer linked to a Customer Type that is not exempt 

from tax will have tax applied. 
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Delete Customer Points when Customer Inactive for Period 

This function adds the option to delete a Customer’s points after the Customer has been inactive for a specified 

period. When this function has been configured, Idealpos will automatically delete any customer’s points who have 

been inactive (not made a transaction) in the configured period. The deleting of inactive Customer points will occur 

when the Idealpos application is started on the terminal and deleted points will be replicated to other Idealpos 

terminals that are configured on the same network. By enabling this function, your Customer Points Liability can be 

maintained as well as encouraging your current and existing customers to remain active so they can retain their points 

balance. Note too that Customer Transaction History and Journal History will remain; only the Customer Points 

balances will be deleted for Inactive Customers in the period. 

 

If you would like to use this function and have imported any customer balances, we strongly advise that you at 

least wait for the desired period of time to lapse before enabling this function. 

E.g. If you want to delete Customer Points for any customers who have been inactive for 12 months, please wait at 

least 12 months after you import Customer balances to allow for those customers to visit your venue and be marked 

as active. Failing to wait for this period before enabling this setting will result in those Customer’s imported points 

balance being deleted.  

The requirement of waiting for the period to lapse is not required if you haven’t imported Customer Balances. 

 

To configure and use this function, go to:  

Setup > POS Terminals > Select the Primary/Main POS Terminal > Modify > Miscellaneous Settings > General > 

Delete Points when Customer Inactive for # Months 

 

 
 

  



Enter the desired number of months into the field. 

When a value of 0 is entered, this function is disabled and no points will be deleted. 

Any other entered value will be used to find customers that were inactive for the specified period and the points 

balance of those inactive customers will be deleted. 

 

 
 

For the setting to take effect, close Idealpos then start it again. 

When Idealpos starts on the terminal, Points will be deleted for any Customers which have been inactive for the 

specified period. 

 

The following explains some important details about how points are deleted when using this function: 

 

• When configuring this function at a venue with multiple terminals networked together, the setting should only 

be enabled on the main/primary terminal. 

Customer Points of any inactive customers will be deleted on the main/primary POS terminal and the packets 

of those deleted points will be sent across to other networked Idealpos Terminals. This will ensure that the 

Customer Balance is consistent across all networked POS terminals.  

• Points deletion occurs when this function is enabled and the Idealpos application is started on the configured 

terminal for the first time in the current month. Points deletion only occurs once each month and once the 

Points Deletion has run for the current month, it won’t run again until the 1st day of the following month. 

• Points are deleted on the 1st day of every month (or the first time the POS terminal is turned on for the current 

month). 

• If a venue is closed and the terminals are switched off on the 1st day of the month, points will be deleted the 

next time the POS terminals are switched on and Idealpos is started  

• When points are deleted, the cut-off date is always the current month minus the number of months specified, 

with the 1st of the Month at exactly midnight (12:00AM) being used as the cut-off date. 

Example Case: Idealpos is configured to delete points when customer inactive for 12 months. 

The current month is June 2019 

The first time Idealpos is started in the current month of June 2019, the system will use a cut-off date of  

1st June 2018 12:00:00AM. 

This means that any customers who have not made a purchase after the 1st June 2018 12:00:00AM will have 

their points deleted. Any customers who have made a purchase after this date will keep their points balance. 

• The Customer Points Report (Reports > Customers > Customer Points) will only show current points and any 

points that have been deleted will not be displayed on the report. 

• “Customer Points Deleted: # months inactivity” will be displayed in the Activity Enquiry, where # will be 

substituted with the number of months that have been configured as the inactivity period.  

• Customer Transaction History/Journal History for any customers who have had their points deleted will be 

retained in the system. Only their points are deleted.  
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To confirm that Customer Points have been deleted, open the Activity Enquiry via Enquiry > Activity Log 

The line “Customer Points Deleted: # months inactivity” will be displayed. 

The below example shows Customer Points Deleted after 12 months of inactivity 

 

 
  



EFTPOS 

First American EFTPOS Integration 

First American EFTPOS Integration has been added to Idealpos and is available to American customers only. 

We recommend researching this additional software before attempting to configure it. 

 

First American EFTPOS requires that the following steps to be completed: 

 

• Installing Java Runtime Environment (JRE) 8.0 or higher 

• Connecting the First American pinpad to the system 

• Installing and configuring the First American 1st Pay mSDK Server/Client 

• Licencing First American in Idealpos Licence Gateway 

• Enabling the First American EFTPOS in Idealpos POS Terminal settings 

• Closing the Idealpos suite then opening it again in order for the changes to take effect 

• Setting up the printer 

 

For further information on configuring this EFTPOS integration, please refer to the First American topic in the EFTPOS 

section of the Idealpos User Guide. 

 

 

  

https://userguide.idealpos.com.au/#EFTPOS/First American/First American.htm
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Westpac Group EFTPOS – POS ID description setting for Pairing 

This function allows a Westpac Group EFTPOS pinpad to remain connected to the POS Terminal after changing a POS 

Terminal’s description in Idealpos. 

When using previous builds of Idealpos, changing a POS Terminal Description (Setup > POS Terminals > Modify > 

Description) would result in the pairing status between the Westpac Group EFTPOS Pinpad and Idealpos being lost. 

You would then have to re-pair the Pinpad with the POS Terminal again after changing the POS Terminal Description. 

With this enhancement, a new POS ID field has been added to the EFTPOS Settings screen and this POS ID is used to 

pair the Pinpad with Idealpos instead of the POS Description. This therefore allows the Westpac Group EFTPOS Pinpad 

to remain paired with the POS Terminal after a POS Terminal’s description has been changed. 

 

There is no extra configuration required when upgrading a system that is already configured with the Westpac Group 

EFTPOS integration as the pinpad will remain paired.  

However, when pairing a POS Terminal that hasn’t previously been configured with a Westpac Group EFTPOS pinpad, 

you will need to enter the POS ID as well as the Pinpad IP Address when pairing the Pinpad. 

 

Go to: Setup > POS Terminals > Select terminal > Modify > EFTPOS Settings > EFTPOS Type: Westpac Group > 

Pairing: POS X > Enter POS ID and IP Address 

The POS ID is typically the terminal description. The description entered into the POS ID field will appear on the screen 

of the pinpad 

 

 
 

  



After pairing the pinpad with Idealpos, the POS ID description is displayed on the pinpad. 

The pinpad will remain paired with the entered POS ID, even if the POS Terminal description is modified: 
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Function Descriptors 

Cash Discount Function 

This function adds the ability to setup a Cash Discount on the Cash Tender. When customers pay using cash, they will 

automatically receive the percentage discount that has been configured against the Cash Function Descriptor.  

This function may be used as an incentive to encourage your customers to pay for their items using cash. 

If you have a Customer Display configured and enabled on your POS terminal, text will also be displayed on the 

Customer Display and will show the Customer how much they can save if they pay using Cash.  

 

To configure this function, go to: Setup > Function Descriptors > Select Cash from the list of Functions > Modify 

 

 
 

  



Enter a value into the Discount % field. The default value entered is 0.00 which indicates that a discount will not be 

applied when paying for the sale using Cash. Entering value into the Discount % field will trigger that percentage to be 

discounted from the total sale amount when pressing the “CASH” button on the Tender screen. Once the required 

Discount % has been entered, press the Save button on the bottom-right corner of the screen. 

 

  
 

Close the Function Descriptors screen. 
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If you have a Customer Display and you want your customers to see a message at the bottom of the screen, ensure 

that you have a Bottom Message configured for the Customer Display. The same portion of the Customer Display will 

also be used to show the Customer how much they’ll save when they pay with cash. 

Go to: Setup > POS Terminals > Select terminal > Modify > Display/Kiosk > Bottom Message 

 

 
 

Once you have configured the Bottom Message, close the POS Terminals configuration screen, then open the POS 

screen on the terminal. 

 

  



Add items to the sale, then press the “Enter” button to go to the Tender screen. 

 

The Clerk operating the POS terminal will see the discounted Cash amount on the Cash button which the Clerk can 

verbally communicate to the customer if your venue does not have a Customer Display. 

In addition, if you do have a Customer Display, the Discount amount will be shown at the bottom of the Customer 

Display when the Clerk operating the POS terminal is viewing the Tender screen at the final stage during the sale. 

 

 
 

 
After pressing the “CASH” button on the Tender screen, the POS will display the discounted cash amount in a prompt. 
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If Receipts are turned on, pressing OK will trigger a receipt to be printed and the Cash Discount amount will be 

included on the customer receipt. Otherwise, press the Receipt button to print off a Customer Receipt. 

 

 

  



Functions 

Gratuity % Functionality 

This function adds the ability to pre-configure a gratuity percent amount on a POS screen button. When the Clerk 

presses the button, the POS will use the pre-configured percentage to calculate the gratuity amount based on the 

total amount in the sale. This function is typically known as Tipping where a customer can tip an amount. 

Using this function, either a single button can be created with a typical percentage tip amount, or numerous buttons 

can be created for the most popular tip percentage amounts at the venue. 

 

Before setting up this function, ensure that you have a Received Account configured as a Tips function. 

 

Go to: Setup > Function Descriptors 

By default, any Received Account descriptors that have not been configured will be labelled as RA 1 to RA 4. 

The descriptors configured for each Received Account function should be labelled so the function resembles the 

intended purpose (e.g. TIPS IN, PAID IN, Gift Voucher Purchase, etc.).   

If you already have a TIPS or TIPS IN label against one of the Received Account functions, you can skip this step. 

 

Select the next available Received Account descriptor that is labelled as RA # and press the Modify button on the 

bottom-right corner.  

 

Enter a description of TIPS IN, then press the Save button on the bottom-right corner of the window. 
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After assigning the TIPS IN function to a Received Account function, we recommend that you update any interfaces in 

Idealpos that support a TIPS function so that they use this Received Account function.  

Examples of such interfaces are EFTPOS, Tyro Pay@Table, Clipp Interface, etc.  

These are configured in Setup > Global Options > Interfaces 

 

If using integrated EFTPOS, ensure that the correct TIPS function is selected in:  

Setup > POS Terminals > Modify > EFTPOS Settings > Tips Function 

 

Once the above has been configured/confirmed, go to: Setup > POS Screen > POS Screen Setup  

Select a tab on the POS screen where you’d like to create the buttons. 

Typically, Tip buttons exist on an Admin or Clerk functions tab, however, your POS screen setup may differ or you may 

want to add them to another tab as required. 

 

Once you have selected the desired tab, click on a blank button.  

Configure the button as below, taking note that the Automatic Text field is the field that will define the percentage 

amount. Adjust the amount in the Automatic Text field as required. Also, enter a Button Caption that reflects the TIP 

function as well as the percentage amount. 

 

Function: Received on Account 

Automatic Text: [10%] 

Received on Account: TIPS IN 

Button Caption: ADD TIP 10% 

 

 
 

You may want to repeat the above steps for various TIP amounts as required. 

Once the buttons are created, close the POS screen layout windows and return to the POS screen. 

  



Add items to the sale as you normally would. 
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Once the items have been added, press the required “Add Tip” button. 

Note that the Add Tip button can be pressed at any time during the sale, however, it will only calculate the tip amount 

based on the current total amount of the sale. 

The below example shows the result of pressing the “ADD TIP 10%” button. 

The Tip amount is automatically calculated and added to the sale, based on 10% of the sale total.  

In this example, the Tip amount is $6.50 (10% of $65.00). 

 

 
 

 

 

  



Kiosk 

Basic Kiosk Functionality 

This function adds basic Kiosk functionality to Idealpos. A POS terminal can be configured as a Kiosk so that customers 

can place their orders at a terminal in a similar way that is offered in many fast-food restaurants. 

 

Please be aware and take note of the following points before demonstrating/using the Kiosk function in Idealpos: 

 

• Kiosk is enabled in the licence, therefore needs to be purchased to use this function on a permanent basis 

• Kiosk module cannot be licenced together with Back Office or POS Screen on the same terminal (this 

restriction does not apply when demonstrating this function on a system with a Demo Licence) 

• Kiosk is designed to run in portrait orientation at a resolution of 1920x1080 

• The Demonstration Database included with Idealpos contains a Kiosk POS Screen Layout in portrait 

orientation that can be used for demonstrating the Kiosk function 

• To demonstrate this function, a Full System Reset must be performed on a non-production terminal. This will 

result in all Idealpos settings being erased, so therefore should only be done on a demonstration terminal 

• To demonstrate this function, the screen orientation in Windows will need to be changed to portrait  

 

To configure and enable the Kiosk function, start IPSUtils. 

This can be done by opening the Windows Start menu, entering IPSUtils into the search, then starting IPSUtils. 

Within IPSUtils, click on the Advanced tab, then click on “Full System Reset” 
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If prompted, enter the Admin password, then confirm the reset by either pressing each character on the screen, or 

type in “confirm” using your keyboard. After confirming, the OK button will become available. 

Press OK to continue with the System Reset. 

 

 
 

After the system reset has been completed, the following “IPSClient ready” prompt will appear on the bottom-right 

corner of the screen. Double click on the spinning IPSClient logo. 

 

 
 

On the following prompt, select “Create Demonstration Database” then press OK. 

 

 
 

  



Idealpos will Create the Demo Database along with any other steps that are required for Idealpos to function. 

 

 
 

When complete, the Idealpos POS screen will be displayed. 

Close the POS screen using the “X” button on the top-right corner of the screen. 

Then go to: Setup > Licence Gateway 

Change the POS Number to 2 
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Click in the dropdown box next to Options, then disable “POS Screen” and enable “Kiosk”. 

 

 
 

  



Press the “OK” button on the bottom-right corner of the screen to save the changes. 

 

 
 

You will need to restart Idealpos for the change to take effect. IPSUtils can be used to close Idealpos. 

Go to:  

Start > Search for “IPSUtils” then once it is displayed, open it > Enable Checkbox: Close IPS Utility > Close 
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Select “Yes” when prompted to close the Idealpos Suite of programs. 

 

 
 

As the Kiosk module is designed to run on a portrait orientation screen, you will need to adjust the Windows display 

settings so that the screen is rotated and displayed in portrait mode. 

On a Windows 10 system, this can usually be achieved by right-clicking anywhere on the Windows desktop and 

choosing “Display Settings”, then changing the orientation from Landscape to Portrait.  

Note however that this may differ depending on the version of Windows installed as well as the Windows Display 

Drivers. 

 

 
 

  



Once the Windows Display Orientation has been changed to Portrait, you may start Idealpos. 

After Idealpos starts, it will display a “Kiosk” POS Screen layout that can be used to demonstrate the Kiosk module. 

The first screen that appears will be an ORDER HERE screen to draw the customer’s attention towards the Kiosk. 

The image used below can be modified by going to:  

Setup > POS Terminals > Select POS Terminal > Modify > Display/Kiosk > Kiosk > Home Screen Image 
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Clicking or pressing anywhere on the screen will reveal the built in Kiosk POS Screen Layout included in the Idealpos 

Demo Database. This can be used to demonstrate the various possibilities when using a Kiosk layout. 

POS screen tabs included in the Kiosk Demo are BURGERS, SIDES and DRINKS. 

The main buttons available on the top-right corner of the POS screen are:  

REMOVE ITEM – Select any item that has been added to the sale then press REMOVE ITEM to remove the item 

CANCEL SALE – Removes all items from the sale then returns to the ORDER HERE – TOUCH TO BEGIN screen  

CHECKOUT – Proceeds to the CHECKOUT screen where customer makes their payment 

 

 
  



When configuring the Kiosk function, the following functions may be useful: 

• Exit POS Password – Can be used to prevent the customer from exiting the POS screen on a Kiosk. 

To configure/enable this function, go to: Setup > Global Options > General > Exit POS Password 

When the Exit POS Password is blank, the POS screen can be closed without entering a Password. 

When a password has been configured, the POS screen will prompt for a password to be entered when 

attempting to close the POS screen. 

 
 

 
 

• Options in Setup > POS Terminals > Display/Kiosk > Kiosk 

The following settings are available: 

Top Image Location – Can be used to specify the folder containing the images or videos that will be shown at 

the top of the Kiosk screen. The component used to display videos is Windows Media Player, but you will need 

to check your videos before use, as not all formats may display correctly.  

Typically, .avi and .wmv files will play with no issue. 

Bottom image – Can be used to specify an image to display at the bottom of the Kiosk screen. 

Home Screen Image – This setting can be used to display a Home Screen Image on the Kiosk before the 

customer starts using the Kiosk. Typically, this can be a Welcome or Order Here image. 

This setting will override any image configured in Global Options > Other Options > Home Screen > Home 

Screen Graphic 

Clerk – Allows you to specify the Clerk that you want to use for the Kiosk. You may want to create a new Clerk 

for the specific purpose of Kiosk use. This may assist when running reports for sales performed at Kiosks. 

 

• When creating Kiosk POS screen buttons, Carriage Returns are now supported and may be used to move POS 

screen button text onto the next line. The Carriage Return character is the tilde “~”.  

This character can be entered into the button caption field when creating new or modifying existing POS 

Screen buttons via Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons > Select 

exiting button/Create new button 

More information on this function can be found within this Update History document – see “POS Button 

Captions can include Carriage Returns” under the POS Screen Setup topic. 
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Laybys/Layaways 

Layby Descriptor programmable through Function Descriptors 

This function adds the ability to control the name used to refer to the Layby function in various screens, menus and 

reports in Idealpos. The name Layby is used in Australia, New Zealand and South Africa. Other regions may refer to 

Laybys as Layaways and Idealpos has been updated to allow for customers in those regions to customise Idealpos for 

their region. 

 

To configure this function, go to: Setup > Function Descriptors. 

 

There are two Function Descriptors that need to be updated:  

• Tender Descriptor – Used for the Layby/Layaway tender (shown on the Tender screen when finalising the sale) 

• Layby Descriptor – Used to control whether Idealpos uses the Layby or Layaway description throughout the 

program 

 

From the list of Function Descriptors, look for a Tender configured with a Description of “LAYBY”, select it, then press 

the “Modify” button on the bottom-right corner of the Function Descriptors window. If the Layby Tender does not 

exist yet, you will need to select the next available/unused tender and assign it to the Layby function (unused Tenders 

will typically have a description that matches the Function. E.g. The TENDER 5 Function will have a Description of 

TENDER 5 indicating that it hasn’t been configured or used). 

Modify the Description to LAYAWAY and ensure that the “Layby Tender” is ticked (note that the descriptor for the 

Layby tickbox will be updated once all the steps have been completed below). 

 

 
 

  



Then scroll to the bottom of the Function Descriptors window, select the “Layby” Descriptor and press the “Modify” 

button. 

Change the description to “Layaway”, then press the “Save” button on the bottom-right corner. 

 

 
 

After pressing Save above, close the Function Descriptors screen. 
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To ensure that the change has been applied across the Idealpos application, close Idealpos by going to Start > Search 

for “IPSUtils” then open IPS Utility. 

Tick the “Close IPS Utility” tickbox then press the “Close” button. 

 

 
 

A prompt will appear, press “Yes” to confirm. 

 

 
 

  



Start Idealpos again via the Windows Start Menu and login if required. 

The Layby function has now been renamed to Layaway. 

To confirm, the change, you may go to Reports > Customers > Layaway Transactions/Layaway Report 

The above report options were previously referred to as Layby Transactions and Layby Report 

 

 
 

In addition to the above, there are many other locations in Idealpos that will reflect the updated Layby Descriptor, 

including Functions, Layby functions on the POS screen and many others. 

For more information about setting up and using Laybys or Layaways, please refer to the Laybys/Layaways topic in the 

User Guide.  

https://userguide.idealpos.com.au/Content/Laybys/Laybys.htm
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Layby Functions separated from Account Functions 

This enhancement assists users with the configuration of Layby or Layaway Functions (Layby Adjustment, Layby 

Cancellation, Layby Credit and Layby Payment) in regions where Laybys are referred to by another term such as 

Layaways. When the Layby Descriptor has been renamed to Layaway or any other name, the Layby Functions displayed 

in the Functions list will be reflective of the chosen name. 

Apart from separating the Layby Functions from the Account Functions for the purposes of easier identification and 

easier configuration in some regions, the functionality and behaviour for the separated functions remains the same 

and can be used interchangeably (e.g. configuring a POS screen button to use the Account Adjustment Function or 

Layby/Layaway Adjustment Function will do the same thing and allow an Adjustment to be performed on the Account 

or the Layby/Layaway). 

 

To use this function, go to: Setup > Function Descriptors > Select Function Descriptor “LAYBY” > Modify 

Modify the description to reflect the name that you want Laybys to be referred to as.  

In the below example, we’ve used “Layaway” 

 

 
 
Press the “Save” button to save changes, then close the Function Descriptors window. 
 
  



Go to Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Press the “Buttons” button on the 
bottom-left corner. 
 
On the POS Screen Layout, find a blank button and click on it. 
Look for the Functions Layaway Adjustment, Layaway Cancellation, Layaway Credit and Layaway Payment in the list 
of available Functions. The description of these functions will be reflective of the description that was entered for 
the Layby Function in Setup > Function Descriptors > Layby > Modify. 
 

 
 
Select any one of these functions as required, adjust the button appearance as desired, then press the “Save” button 
to save changes. This may be repeated for each Layaway function that is required. 
 
For more information about using Laybys/Layaways and these Layby or Layaway Functions, please refer to the 
Laybys/Layaways topic in the User Guide.  

https://userguide.idealpos.com.au/Content/Laybys/Laybys.htm
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Pending Sales 

Pending Sales – Added Unit Price column 

This function adds a Unit Price column when printing a Pending Sale using the Windows Print button. This is useful 

when needing to quickly see the individual unit price of an item where multiples of the same item have been ordered.  

Note that in order to use Pending Sales with the Unit Price column, the following must be configured:  

• POSServer must be enabled and running 

• Inhibit Amounts on A4 Windows Prints must be unticked in Global Options > Sales > Pending Sales > Inhibit 

Amounts on A4 Windows Prints 

• A Pending Sale button needs to either exist or be created on the POS screen 

 

These steps are outlined in further detail below: 

 

Ensure that POSServer is running on either the main Back-Office system or the main POS terminal. 

This can be checked by going to: Start > search for POSServer and open POSServer. 

If POSServer cannot be found in the Start Menu, it can also be started by going to:  

C:\Program Files\Idealpos Solutions\POSServer\POSServer.exe and running as Administrator (right-click on the 

executable and select “Run As Administrator”) 

 

Ensure that “Running” is displayed on the bottom-left corner of the POSServer Configuration window. 

 

 
 

  



If the POSServer is not running, click on the Advanced tab, then press the “Service” button. 

 

 
 

Press the “Start” button to start the Service, then Set the Startup state of the service to “Automatic”, followed by 

pressing the “Set State” button to apply the change. 
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Then ensure that POSServer is enabled in Idealpos Global Options and ensure that the IP address of the system 

running the POSServer has been entered. 

Go to: Setup > Global Options > Miscellaneous > POSServer 

The below example shows Idealpos pointing to a POSServer running on an IP address of 192.168.1.95. 

Substitute the IP address below with the IP address of the system that’s running the POSServer on your network 

 

 
 

Then disable “Inhibit Amounts on A4 Windows Prints” by going to:  

Setup > Global Options > Sales > Pending Sales > Inhibit Amounts on A4 Windows Prints. 

 



 
Finally, add a button to the POS Screen to enable access to the Pending Sale function. 

 

Go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

Find a blank button on the POS screen and select it. 

Configure the button using the Pending Sale function as per the below example: 
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Once the above steps have been completed, the Pending Sale function can be accessed via the Pending Sale button 

on the POS Screen. 

Add the required items to the sale.  

Where a quantity greater than 1 is required for an item, enter the quantity required, press the “X” button, then press 

the POS Screen button for the item required. 

Once the required Stock Items have been added to the sale, press the “PENDING” POS screen button that was created 

earlier above. 

 

 
 

  



Enter the Customer Name, Address and Pending Sale Type, followed by pressing the Save button. 
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After the Pending Sale has been saved, retrieve the Pending Sale by pressing the “PENDING” button on the POS 

Screen, select the Pending Sale from the list and press the “Windows Print” button on the bottom-left corner of the 

screen. 

 

 
 

  



The Pending Sale will be printed and will now include a Unit Price column containing the Unit Price of the items in the 

Pending Sale. 
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POS Screen 

Table Balance Amount shown on POS Screen 

This function adds the ability to show the Table Balance on the POS Screen when adding additional items to a table 

which already contains a sale or when paying off items from a table.  

There is no configuration required to enable this function, however, this function requires the Restaurant Module in 

the Idealpos Licence. 

 

To use this function, go to the POS Screen and press the Table Map button. 

Finally, select a table which contains Stock Items, then press the POS button. 

 

 
 

  



The Sale screen will be displayed and will now show the Table Balance on the left-hand side just below the white 

transaction details area as per the below example. The Table Balance includes any items that are currently saved to the 

table and the amount shown below the transaction details on the right-hand side of the screen refers to the total 

amount of all the items which have been added to the current sale: 

 

 
  

The Balance is also displayed when paying off either selected items from a table or paying off an entire table. 

From the Table Map, select a Table and press the “Pay All” button. 
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All items from the table are moved to the sale screen and can be paid off. The Balance is also displayed as per the 

below example. Note that the Balance amount does not include discounts. 

 

  



Table Preview Show Seat Numbers 

This function adds the ability to see the Seat Numbers that each Stock Item has been allocated to when using Table 

Preview function from the POS Screen. The Table Preview function can be used while you are adding additional items 

to a table and need to view the current items which are already saved to the table, along with the seat numbers the 

items have been allocated to. 

 

This function itself does not require any configuration, however, Idealpos may need additional configuration to enable 

the ability to set Seat Numbers for each Stock Item. 

 

We recommend adding a Seat Number button to the POS Screen to allocate items in a sale to a Seat Number. 

To add the Seat Number button to the POS Screen, go to:  

Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

Find a blank button on any POS Screen tab, then select it. 

You may want to have the Seat Number button on a prominent location on the POS Screen such as the top-right 

corner of the POS Screen. Any buttons configured on the Top-Right corner of the POS screen do not change, 

regardless of what POS Screen tab you are using. 

Configure the button as follows, making any other Button Appearance customisation changes as desired: 

 

 
 

Once completed, press the “Save” button, then close the POS Screen Layout window. 
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Open the POS screen, then navigate to the tab where you created the Seat Number button and press it. 

“SEAT 1” will be displayed at the top of the POS Screen. 

 

 
 

  



Add any items that are being ordered by the customer who will be seated at Seat 1. 
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To switch to the next seat number, press the Seat Number button again and the Seat Number displayed at the top of 

the POS Screen will increment by 1 and show SEAT 2. 

You may then add items that are being ordered by the customer who will be seated at Seat 2. 

 

 
 

The above process can be repeated until items have been ordered for each Customer seated at a table. 

To clear the Seat Number function, press the “SEAT #” text at the top of the POS Screen when on a blank Sale Line. 

 

 
 

The “SEAT #” text will then disappear from the top of the POS Screen. 

  



When the Seat Number function is not active (SEAT # is not displayed at the top of the POS Screen), you may click on 

any Stock Item in the Sale and the Seat Number that the item was allocated to will be displayed at the top of the POS 

Screen. You might also see the Clerk name displayed in yellow at the top of the POS screen, depending on how 

Idealpos has been configured. 

 

 
 

Once the sale is ready to save to a table, press the “TABLE MAP” button and select a table from the Table Map and 

enter the number of Covers if prompted. 
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Now that items have been saved to the table, the Customer might come back at a later time and request to order 

additional items for their table. 

Press the “TABLE MAP” button, select the Customer’s table and press the “POS” button. 

The below example shows table 83 selected and the location of the POS button. 

 

 
 

  



The POS screen will be displayed and will show the Table number along with the number of Covers for the table. 

To view the Table Summary, simply press the Table number on the Sale Screen. 
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The Table Summary screen will be displayed and will show the Table Number, Balance, Stock Items saved to the table 

along with the Seat Number that each item has been allocated to. 

Seat Numbers are displayed in square brackets. 

The below example shows that the first Stock Item “CAPPUCCINO” is allocated to Seat Number 1. 

 

 
 

 

 

 

  



POS Screen Setup 

POS Button Captions can include Carriage Returns 

This function allows further control of POS Button Captions by adding the option to include carriage returns anywhere 

in the button caption. The carriage return character is the tilde symbol “~”. Any text that is entered after a tilde “~” 

symbol within a button caption will be displayed on the next line. 

 

To use this function, go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

 

Either select an existing button on the POS screen which you want to include Carriage Returns in the caption or create 

a new button. 

The below example shows modifying an existing button. 

 

Click on the button, then in the button caption, enter a tilde “~” symbol anywhere that you’d like to have the text 

move onto a new line. The button appearance displayed on the left-hand side of the screen will update on-the-fly as 

you make your change. 

Once you have made the change, press the “Save” button and the change will be visible in the POS Screen Layout. 

 

 
 

Close the POS screen layout and the change to the button will be applied. 

Repeat the above process for any other buttons that require changing. 
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Price Enquiry Function allows Selling of Item 

This function adds the ability to sell an Item from the Price Enquiry screen. 

When performing a Price Enquiry, Idealpos will show the Stock Item, Stock Item Price as well as a SELL ITEM button. 

This allows the operator to add the item to the sale should the customer decide to purchase it at the price displayed 

on the POS screen. In addition, the SELL ITEM button is also available on the top-right corner of the applicable 

promotions screen when accessed via the Price Enquiry screen.  

Note that this function (Selling of Item from Price Enquiry) is unavailable when checking more than one item’s price at 

a time using the MULTI option. 

 

To use this function, go to:  

Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons > Create a new button as follows: 

 

 
 

Press Save, then close the POS layout screens. 

Go to the POS screen > Press the Price Enquiry button > Press a Stock Item button 

Idealpos will display the Stock Item Description, Price, a SELL ITEM button and depending if the Stock Item has any 

applicable promotions, an option to view applicable promotions is also available. 

 

The below is an example of a Price Enquiry on an item which has available promotions. 

Pressing the “SELL ITEM” button will add the item to the sale and dismiss the Price Enquiry prompt. 

 

 
 

  



In addition to being able to sell the item from the above screen, it is also possible to sell the item when viewing the 

applicable promotions. 

Press the “Yes” button on the prompt to view applicable promotions: 

 

 
 

A SELL ITEM button is displayed on the top-right corner of the promotions screen which can also be used to add the 

item to the sale. Pressing the “SELL ITEM” button will add the item to the sale and dismiss the promotions screen. 

 

 
 

When performing a Price Enquiry on an item which doesn’t have any promotions available, the Price Enquiry screen 

will be displayed as follows. The available options are “OK” or “SELL ITEM”.  

Press “SELL ITEM” to add the item to the sale or press the “OK” button to dismiss the prompt and return to the sale 

screen without adding the item to the sale: 
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Stock Level Enquiry Function for POS Screen 

This function allows the ability to perform a Stock Level Enquiry from the POS Screen. This may be useful in cases 

where you need to find out the Stock Level of a particular Stock Item in either the current location or any other 

locations which the Stock Item is available. 

 

To configure this function, go to:  

Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons > Select blank button > Configure 

as below, then press “Save” to save the button: 

 

 
 

  



Close the POS Screen Layout windows, then go to:  

POS Screen > Press the Stock Level Enquiry button > Press a Stock Item button on the POS Screen > Stock Level 

Enquiry is displayed: 
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POS Terminal Settings 

Added new Region setting for India 

A new Region setting has been added for India. This setting can now be used by Customers who are located in India. 

When setting Idealpos to the India region, the following changes are included: 

• Indian Currency Denominations for Fast Cash Keys will be displayed on the Tender screen  

• Indian Currency Denominations for Cash Declaration will be displayed on the Cash Declaration screen 

• Tax settings configuration will be changed to allow Indian Taxes to be configured 

 

We recommend that the Windows Region is first configured accordingly and once this has been done, the Idealpos 

region can be configured by going to: 

Setup > POS Terminals > Modify > Main Settings > User Details > Region > India 

 

 
 

After making the above change, restart Idealpos for the change to take effect. 



Tax rates can be configured by going to: Setup > Global Options > Sales > Tax Rates 
 

 
 
When tendering sales in Idealpos, Indian Currency Denominations and Currency Images will be displayed: 
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User Details Copy function 

This function adds the ability to copy the POS Terminal User Details (Region, Address, Postal Address, Email, Phone, 

Fax, ABN, ACN) from POS 1 to any terminal. This function can be used in cases when the User Details need to be 

updated for all terminals but using the existing “Copy from POS #” function would result in each POS terminal’s unique 

configuration being lost. 

Therefore, the Copy from POS 1 button can now be used instead which will allow each POS Terminal’s unique 

configuration to be preserved while allowing the ability to quickly copy the User Details settings from POS 1. 

 

To use this function, go to:  

Setup > POS Terminals > Select POS 1 > Modify > Configure/Update the User Details as required 

 

 
 

To save the change, close the POS Terminal configuration screen for POS 1. 

  



Then select the next POS Terminal from the list and select “Modify” 

Press the “Copy from POS 1” button which will copy All User Details (Region, Address, Postal Address, Email, Phone, 

Fax, ABN and ACN) from POS 1 to the current POS Terminal being modified.  

Close the POS Terminal configuration screen for the POS Terminal and repeat the process for all required remaining 

terminals. 
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POSServer 

Centralised Customer Account/Layby Transactions retrieved from POSServer 

This function enables the ability to centralise Customer Account and Layby Transaction data in the POSServer.  

By centralising Customer Transactions on the POSServer, all terminals will have access to the same consistent 

Customer balances. In addition, a customer can only be added to a transaction at one POS terminal at a time (i.e. a 

customer cannot be added to a sale on two or more POS terminals at the same time, as POS will display a message 

that the customer is currently in use at POS #). 

 

The Centralised Accounts function is disabled by default.  

If you are using multiple POSServers at a site, Centralised Accounts are not supported and should not be enabled. 

 

Before enabling Centralised Accounts, we recommend that the following steps are completed: 

 

• Check and ensure that there are no unprocessed packets for any POS terminals in IPS Client. Confirm this by 

going to the main Back Office terminal and clicking on the IPS Client icon within the Windows System Tray.  

Note that Idealpos must be running in order for IPS Client to appear in the System Tray. 

 

 
 

 
 

• We recommend creating a backup of the Idealpos database for each terminal. 

This can be done either by opening IPS Utils on each terminal and pressing the “Backup” button, or from the 

main dashboard screen at each terminal by going to File > Backup Database, then following any remaining 

prompts to create the backup. 

 

• If POSServer is already configured and in use, we also recommend creating a backup of the POSServer from 

the main terminal which is running the POSServer. Run the POSServer configuration (POSServer.exe) as 

Administrator (right click on the POSServer and choose “Run as Administrator”). A shortcut to POSServer 

should exist in the Windows Start Menu, however, it can also be found in "C:\Program Files\Idealpos 

Solutions\POSServer\POSServer.exe". Press the “Backup” button, then choose a location to save the backup 

and press “Backup” 

 

 

  



Enabling Centralised Accounts involves multiple steps as outlined below: 

Ensure that POSServer is running on either the main Back-Office system or the main POS terminal. 

This can be checked by going to: Start > search for POSServer and open POSServer. 

If POSServer cannot be found in the Start Menu, it can also be started by going to:  

C:\Program Files\Idealpos Solutions\POSServer\POSServer.exe and running as Administrator (right-click on the 

executable and select “Run As Administrator”) 

 

Ensure that “Running” is displayed on the bottom-left corner of the POSServer Configuration window. 
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If the POSServer is not running, click on the Advanced tab, then press the “Service” button. 

 

 
 

Press the “Start” button to start the Service, then Set the Startup state of the service to “Automatic”, followed by 

pressing the “Set State” button to apply the change. 

 

 
 

 

  



Then ensure that POSServer is enabled in Idealpos Global Options and ensure that the IP address of the system 

running the POSServer has been entered. 

Go to: Setup > Global Options > Miscellaneous > POSServer 

The below example shows Idealpos pointing to a POSServer running on an IP address of 192.168.1.95. 

Substitute the IP address below with the IP address of the system that’s running the POSServer on your network 
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Then Enable tickbox “Centralise Accounts” 

 

Once Centralised Accounts have been enabled, we recommend that they remain enabled. This setting shouldn’t be 

toggled on and off. 

 

 
 

  



Customer Account Transactions must also be manually Transferred/Sent from a POS terminal to the POSServer. 
From the main or primary terminal (typically POS 1 at the venue/site), go to: Setup > Global Options > Miscellaneous. 
Within the Transfer section, enable the “Customer Account Transactions” tickbox, then press “Send”. 
You may be prompted to enter the Administrator password. 
All Customer Account Transactions from the current terminal will be sent to the POSServer. 
 

 
 
Once the above steps have been completed, restart Idealpos on each POS terminal. 
This can be done by opening IPS Utils and pressing the “Close” button. 
Go to Start > search for “IPSUtils” and open IPSUtils. 
Tick the “Close IPS Utility” option, then press the “Close” button. 
 

 
 
Confirm any prompts by pressing “Yes” to close the Idealpos suite of programs. 
Then start Idealpos again by either double clicking the Idealpos shortcut on the desktop or by going to the Start 
Menu and going to Idealpos > Idealpos. 
 
Customer Accounts can be used as normal and any User Interface screens will remain the same when using 
Customer Accounts.  
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Additional options for Customer Accounts related functions have also been added to the Global Options > 

Miscellaneous > POSServer section.  

Note that these options are for advanced users and should only be used when you are familiar with their purpose and 

the outcome you are trying to achieve.  

 

• Transfer Customer Account Transactions – This option will Clear Customer Account Transactions from the 

POSServer and replace with data from the current terminal 

 

 
 

• Clear Customer Account Transactions – This option will clear Customer Account Transactions from the 

POSServer 

 

 
 

• Retrieve Account Transactions – This option will clear all Customer Account Transactions on the current 

terminal and will replace with Account Transaction Data from the POSServer. 

 

 
 

 



When using these functions, Idealpos will prompt for the Admin Password, followed by a confirmation prompt 

explaining exactly what the selected option will perform with the opportunity to proceed or cancel via the Yes/No 

buttons. 
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Promotions 

MAXTRIPS tag for Multi-Trip Promotions 

This function adds the ability to specify the maximum number of times that a Multiple Trip Promotion can be tripped 

in a single sale. This can be used where you need to restrict the promotion. An example promotion that may need to 

have the number of trips restricted could include a promotion that gives a Customer a bonus promotional item when 

they purchase either a single Stock Item or a combination of Items. 

 

To use this function, go to: File > Sales > Promotions > Promotions > Select a Promotion > Modify 

 

The below example shows a Promotion which triggers a bonus ICE CREAM HAT Stock Item when purchasing 2x CHOC 

ICE CREAM 1L.  

The MAXTRIPS tag is only applicable to Promotions that have the “Multiple Trips” option enabled, so ensure that the 

Multiple Trips option is enabled on the promotion that you want to limit the number of trips on: 

 

 
 

  



Once you have either created a new promotion with “Multiple Trips” enabled or ensured the “Multiple Trips” option 

has been enabled on an existing promotion, click on the “Advanced” tab, then enter [MAXTRIPS=#] into the User-

Defined field.  

Replace # with the number of maximum trips that you want the promotion to be limited to. 

The below example shows the maximum number of trips set to 3. 

 

 
 

Close the Promotions screen and when prompted, select “Yes” to save the changes. 
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Open the Idealpos POS screen then trigger the Promotion by purchasing the required number of items. 

In this example, the promotion triggers a bonus ICE CREAM HAT Stock Item worth $5.00 when 2x CHOC ICE CREAM 1L 

items are purchased. 

The promotion will be limited to triggering 3 times (MAXTRIPS set to 3).  

Purchasing 6x CHOC ICE CREAM 1L Stock Items will trigger the Bonus Hat Promo 3 times. 

After the max trips have been reached for the promotion, the promotion will not trip again for the current sale. 

After the sale has been tendered and finalised, the promotion can be tripped three times in the next sale. 

 

The below shows the CHOC ICE CREAM 1L item purchased 8 times with [MAXTRIPS=3] enabled. 

Note the Bonus Hat Promo only tripped 3 times which is in accordance with the MAXTRIPS setting. 

 

 
 

When the MAXTRIPS setting has not been set in the Advanced tab, there is no limit to the number of times the 

Promotion can be tripped and the below example shows that the Bonus Hat Promo was tripped 4 times.  

 

 
  



Raffles 

Raffles inhibit redrawing of an already drawn number on multi-draw raffles 

The logic used to draw Raffles in Idealpos has been updated so that it behaves more like a traditional raffle draw.  

After a ticket has been drawn in a raffle, Idealpos will mark that ticket as drawn and if the raffle is drawn again, 

previously drawn tickets will be excluded from the raffle draw. A raffle can be re-drawn again and again until either all 

the tickets included in the raffle are drawn or until the raffle is reset. 

There is no configuration required to enable this function. 

 

See the Raffles topic in the Idealpos User Guide for more information about configuring and using Raffles in Idealpos: 

https://userguide.idealpos.com.au/#Raffles/Raffles.htm 

 

 

    

https://userguide.idealpos.com.au/#Raffles/Raffles.htm
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Reports 

POS Description shows on the Reports header 

This function adds the POS Description to the Reports header for any report that is available via the Idealpos Reports 

menu. The Description of the POS which runs a report will be displayed in the header of the report. 

 

There is no configuration required to enable the POS Description to display in the report header, however, you may 

want to update the POS Descriptions of your terminals so that the correct POS Description is displayed on your 

reports. 

 

To update POS Descriptions, go to:  

Setup > POS Terminals > Select a POS Terminal from the list > Modify 

Modify the Description in the Description field, then close the POS terminals screen. 

Repeat the process for each POS terminal that needs the description updated. 

 

 
 

  



Once the POS Descriptions have been updated, any report can be run from the Reports menu and the POS Description 

will appear on the top-left corner of the report in the Report Header. 

The below example shows the Stock Item Sales Report which is available via Reports > Sales > Stock Item Sales 
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Reports – Customers 

Customer Trial Balance – Option to Force End of Last Month for Scheduling 

This function adds the ability to run the Customer Trial Balance Report with the option to “Force End of Last Month”. 

This is useful in cases where you want to create a Shortcut for the report and when using the shortcut, you want the 

report to use an Aging Date for the last day of the previous month (relative to the current date which you’re running 

the report).  

In addition, the same function can be utilised when including the Shortcut Report in a schedule. 

 

To use this function, go to: Reports > Customers > Customer Trial Balance 

 

Enable the “Force End of Last Month” checkbox, set any other report selections as required, then press “View” to run 

the report: 

 

 
 

  



The report will be displayed using the last day of the previous month as the Aging Date. 

The below example shows the Customer Trial Balance Report Header with an Aging Date of 31/05/2019 and a printed 

date of 19 June 2019. 

 

 
 

From the top-right corner of the screen, press the “S” button to create a shortcut for the Customer Trial Balance 

Report. The Shortcut will include the options that were selected when running the report, including the “Force End of 

Last Month” option. 

 

  
 

Enter a Shortcut Name, then choose a location to save the Shortcut to. 

For this example, we’ll use the “Favourites” location. 

 

 
 

Close the Customer Trial Balance Report. 
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A Shortcut for the Report will now appear on the Back-Office screen under “Favourite Reports”. 

 

 
 

Clicking on the Shortcut will run the Customer Trial Balance using the options that were selected when the report was 

created, including the “Force End of Last Month” Aging Date option. 

 

  



A Schedule can also be created for the Report Shortcut. 

Go to Setup > Schedules > Either select an existing Schedule and press Modify or press the “Add” button. 

Select the required options for the Schedule and drag the “Customer Trial Balance” report from “Shortcut Reports 

Available” to “Scheduled Reports”. 

 

 
 

Once the schedule has been created, close the Schedules screen and select “Yes” when prompted to Save Changes. 

 

 
 

The Schedule will appear in the list of Schedules and will run as per the settings that were configured. 

When run via the Schedule, the report will use the settings chosen in the report, including “Force End of Last Month”.  
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Reports – Sales 

Pending Sales Report – Includes Total by Sale Type Status 

This function adds a Total for each Sale Type that is reported within the Pending Sales Report. 

No additional configuration is required to enable this function; it is enabled by default. 

 

In order to use Pending Sales, ensure that you have POSServer enabled and a Pending Sale button on your POS 

Screen. 

 

The steps to configure Pending Sales and use the Pending Sales Report are outlined as follows: 

 

Ensure that POSServer is running on either the main Back-Office system or the main POS terminal. 

This can be checked by going to: Start > search for POSServer and open POSServer. 

If POSServer cannot be found in the Start Menu, it can also be started by going to:  

C:\Program Files\Idealpos Solutions\POSServer\POSServer.exe and running as Administrator (right-click on the 

executable and select “Run As Administrator”) 

 

Ensure that “Running” is displayed on the bottom-left corner of the POSServer Configuration window. 

 

 
 

  



If the POSServer is not running, click on the Advanced tab, then press the “Service” button. 

 

 
 

Press the “Start” button to start the Service, then Set the Startup state of the service to “Automatic”, followed by 

pressing the “Set State” button to apply the change. 
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Then ensure that POSServer is enabled in Idealpos Global Options and ensure that the IP address of the system 

running the POSServer has been entered. 

Go to: Setup > Global Options > Miscellaneous > POSServer 

The below example shows Idealpos pointing to a POSServer running on an IP address of 192.168.1.95. 

Substitute the IP address below with the IP address of the system that’s running the POSServer on your network 

 

 
 

You will also need a Pending Sale button on your POS Screen to access the Pending Sale function. 

 

Go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

Find a blank button on the POS screen and select it. 

Configure the button using the Pending Sale function as per the below example: 

 

  
  



You may also want to adjust the different types of Pending Sales (such as Pickup, Takeaway, etc.). 

This can be done by going to: Setup > Global Options > Sales > Sale Type Status 

You can modify the Sale Type Status as required: 

 

 
 

Once the Sale Type Statuses have been modified as required, close the Global Options screen and go to the POS 

screen. 

 

Add items as required, then press the Pending Sale button. 
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Enter the Customer Details, select the Pending Sale Status and finally press “Save” to save the Pending Sale. 

 

 
 

Repeat the above process for any other required Pending Sales. 

 

  



Once Pending Sales have been saved, the Pending Sales Report can be run by going to: 

Reports > Sales > Pending Sales > View 

 

The report will list each Pending Sale Type. At the end of each Sale Type, a total amount for all sales of that Sale Type 

will be displayed. 
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Stock Item Sales Report – Clerk Selection Range 

This function adds a Clerk field to the Selection Range in the Stock Item Sales Report.  

This function allows the user to run the Stock Item Sales Report based on either a single Clerk, specific Clerks or a 

range of Clerks.  

This function is useful where you need to report on Stock Item Sales based on the Clerk that completed the sale. 

 

To use this function, go to: Reports > Sales > Stock Item Sales 

 

 
 

  



The Clerk can be reported in the following ways: 

• Single Clerk – Click on the “>” button in the Clerk field, select a Clerk from the list then press OK.  

The single Clerk number will be added to the Clerk field. 

 
 

• Multiple Clerks – Click on the “>” button in the Clerk field, select a Clerk from the list then press OK.  

Repeat this process until you add the required Clerks. Each Clerk number will be listed in the Clerk field, 

separated by a comma. 
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• Clerk Range – Click on the “>” button in the Clerk field, select the first Clerk in the range then press OK.  

Click the mouse cursor into the Clerk field after the Clerk number and enter a hyphen “-“ (when entering the 

hyphen, ensure that the Clerk number is not selected, otherwise it will be overwritten when entering the 

hyphen). Then press the “>” button, select the final Clerk in the range and press OK. The Clerk field will contain 

the two Clerk numbers separated by a hyphen. 

If you already know the Clerk numbers of the Clerk range that you want to report on, you can manually enter 

the range of Clerk numbers into the Clerk field by entering the first and last Clerk numbers, separated by a 

hyphen “-“. 

 
 

 

  



Once you have selected the required Clerk(s) in the Selection Range along with any other desired report options, press 

the “View” button on the bottom-right corner of the Stock Item Sales window to run the Report. 
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The report will be displayed and will display report data based on the selections that were chosen.  

 

  



Stock Item Sales Report – Group by Audit 

This function adds the ability to group the Stock Item Sales Report by the Audit number.  

Each sale that is completed in Idealpos has an Audit Number associated with it. 

When running the Stock Item Sales Report with the Group by Audit option selected, the report will list each Audit 

Number that occurred in the selected period along with the items that were purchased in each Audit Number. 

 

To use this function, go to: Reports > Sales > Stock Item Sales 

Select the desired Date Range. 

Within the Optional Grouping section, select the Group Field “Audit” from the dropdown box. 

Press the “View” button on the bottom-right corner to view the report 
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The Stock Item Sales Report will be displayed and will be grouped by the Audit Numbers that occurred in the selected 

period. The Stock Items purchased within each Audit Number will be displayed below the Audit Number. 

 

  



Stock Item Sales Report – Group by Sale Type 

This function adds the ability to group the Stock Item Sales Report by Sale Type (e.g. Takeaway, Delivery, Pickup, Cater, 

etc.). to the Optional Grouping – Group Field section of the Stock Item Sales Report. 

When the “Sale Type” option has been selected from any of the dropdown boxes in the Option Grouping – Group 

Field section, a Sale Type dropdown box will appear in the Selection Range section. Through the use of this function, it 

is now possible to group the Stock Item Sales Report by Sale Type. As this this function will report on existing sales 

that have already been performed, you will need to have pre-existing sales with Sale Types recorded against them. 

 

If this reporting function is something you want to make use of but you haven’t been recording Sales Types against 

your POS transactions, you will need to ensure that buttons have been configured on the Idealpos POS screen to allow 

you to choose the Sale Type for future POS transactions. 

 

To do this, go to: Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 

Find a POS Screen tab which has blank/available buttons and select a blank button. 
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Select the “Sale Type” option from the list of Functions, then select the desired Sale Type from the Status dropdown 

box. If required, you may also select another Price Level (e.g. you might sell a meal at a different price for a Delivery 

Sale Type compared to a meal that is sold for a Pickup Sale Type).  

Once you have finished configuring the Sale Type button, press the “Save” button. 

 

 
 

Repeat the above steps to create additional buttons for each Sale Type as required. 

Once finished creating the Sale Type buttons, close the POS Screen Layout windows. 

  



When performing a sale in Idealpos, press the desired Sale Type button anytime during the sale to set the Sale Type. 

After pressing a Sale Type button, you will notice the Sale Type will be displayed on the top-right corner of the screen. 

Note that if you accidentally press a Sale Type, you can remove the Sale Type from the sale by pressing the Sale Type 

text at the top of the POS screen 

The below example shows the Sale Type displayed on the top-right corner of the screen: 
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To use the Sale Type function in the Stock Item Sales report, go to: Reports > Sales > Stock Item Sales. 
From the Optional Grouping – Group Field section, select the “Sale Type” option from any of the available dropdown 
boxes: 
 

 
 
Under the “Selection Range” section, you will find a “Sale Type” dropdown box – select the desired Sale Type that 
you want to report on. Selecting the “All Sale Types” option will report on all Sale Types (including sales which 
haven’t had a Sale Type specified), with each Sale Type listed and grouped under its own heading (the heading will 
be displayed provided that the “Show Group Label” option has been enabled for the Group Field). Selecting any of 
the other Sale Type options will only display the selected Sale Type on the report. 
 

 



Once you have selected the desired options for the Stock Item Sales Report, press the “View” button located on the 
bottom right corner of the screen. The report will be displayed and will be grouped by the Sale Type. As mentioned 
previously, any items sold in transactions where a Sales Type was not specified will be listed under “No Sale Type”, 
with all other Sale Types listed under their respective headings. 
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Stock Item Attributes 

Stock Item Attribute to Remove Tax on Take-Away Items (Canada/USA) 

This function adds the ability to stop tax from being applied to specific items that are sold as a Takeaway (e.g. when a 

customer orders a meal, then takes it away and consumes it elsewhere). This option only applies to and affects systems 

which are configured to use the Canada/USA region  

(Setup > POS Terminals > Select Terminal > Modify > Region: Canada / USA). 

 

To configure and use this function, go to Setup > Global Options > Sales 

Under “Sale Type Status”, ensure that you take note of the exact way the Takeaway text has been entered 

 

 
 

  



Close the Global Options screen.  

Go to File > Sales > Stock Item Attributes > Add New Attribute Type > Enter “Remove Tax” into the Add Attribute 

Type field, then press “Save”. 

 

 
 

Close the “Add Attribute Type” screen by pressing the “X” on the top right corner of the screen. 
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Then select the “Remove Tax” Attribute Type followed by pressing the “Add New Remove Tax” button 

 

 
 

  



Next to the “Add Remove Tax” field at the bottom of the screen, enter Sale Type=Takeaway 

Note that when adding this Attribute, the Takeaway text must be entered exactly the same as it appears in Global 

Options > Sales > Sale Type. 

Press “Save” to save the Attribute. 

 

 
 

Close the Add Attribute and Stock Item Attribute screens. 
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In order to specify a Takeaway Sale Type during a sale, you will need to ensure that you have a Takeaway Sale Type 
button on the POS Screen. 
Go to Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 
Find a blank unused button on the POS screen, click on it and configure it as follows then press “Save”: 
 

 
 
Close the POS Screen Layout screens. 
 
The Special Attribute Types – Remove Tax option needs to point to the Remove Tax Attribute Type. 
Go to: Setup > Global Options > Other Options > Special Attribute Types 
Select the Remove Tax option from the Remove Tax dropdown list. 
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Close the Global Options window to save the change. 
 
The final step is setting Attribute Types on any Stock Items which should not be taxed when sold as a Takeaway. 
Go to File > Stock Control > Stock Items > Select an Item > Modify 
On the bottom-right corner of the Stock Items screen under the Attributes Section, select the “Remove Tax” option 
from any of the left-hand side dropdown boxes. 
The corresponding dropdown box on the right-hand side should automatically pre-select the “Sale Type=Takeaway” 
option as per the below example: 
 

 
 
Press the “Save” button to save the change and repeat the above process for any other Stock Items which should 
have tax excluded when they are sold as a Takeaway. 
 
  



Once you have set the Attributes for all Stock Items that need to be excluded from tax when sold as a Takeaway, 
close the Stock Items screens then go to the POS screen. 
Press the Takeaway button, then add the item to the sale which had the Remove Tax Attribute configured. 
When the Takeaway Sale Type button has been pressed, Takeaway will appear on the top-right corner of the screen 
(this can also be pressed to clear/cancel the Takeaway Sale Type from the current sale).  
Any items that are added to the sale and have had the Remove Tax Attribute configured will appear with a hyphen 
(-) in front of the Tax Rate IDs. This indicates that the item will be exempt from tax. Any items that have not had the 
Remove Tax Attribute set will show a Tax ID without a hyphen. The Tax ID values displayed on the Sale screen 
correspond to the Tax that has been enabled for the Stock Item (File > Stock Control > Stock Items > Select Item > 
Modify) and what position the enabled Tax Rate appears in Setup > Global Options > Sales > Tax Rates. 
 
The below example shows EGGS ON TOAST have been exempt from tax and CAPPUCCINO will have tax applied: 
 

 
 
Press the “Enter” button to go to the Tender screen. 
Tax is only applied to items which are not exempt from Tax. 
The sale can be finalised by selecting a tender type or cash amount. 
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When the Takeaway button has not been pressed, any items that have had the Remove Tax Attribute configured will 
show the tax identifier without a hyphen indicating that tax is applicable to those items. 
 

 
 
Pressing the “Enter” button to go to the Tender screen shows that Tax has been applied to all items. 
The sale can be finalised by selecting a tender type or cash amount. 
 

 
 
  



Stock Items 

DOB2 Tag for Stock Item Sales prompt can handle Specific Date 

The DOB2 field in a Customer record is typically used by Clubs to store the Membership expiry date of the Customer. 

The DOB2 of a Customer can be updated automatically when a Stock Item is added to a sale (such as when the 

Customer purchases a Membership Stock Item). This is achieved by entering a #DOB2 tag into the Sales Prompt field 

of the Stock Item. 

 

This function adds the ability to set a Specific Date when using the DOB2 tag (in addition to still having the ability to 

increment the Customer’s DOB2 by a specific number of months). 

 

Some clubs may want all their members to have the same expiry date, regardless of when the membership was 

purchased and this function can be used in these cases. 

 

To configure and use this function, go to: File > Stock Control > Stock Items > Open/Create a Membership Stock Item. 

If creating a new item, ensure that you fill out the required details. 

The below example shows a Membership Stock Item (based on the Annual Membership Stock Item that is included in 

the Idealpos Demonstration Database) 
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Once the Membership Item has been created, open the Stock Item and click on the Advanced tab. 

In the Sales Prompt field of the Advanced tab, enter the DOB2 tag. 

You have the following options: 

 

• Increment the DOB2 by a specific number of months 

To achieve this, enter #DOB2=NumberOfMonths 

E.g. #DOB2=12 

 

 
 

• Set the DOB2 to a specific date 

To achieve this, enter #DOB2=DD/MM/YYYY 

E.g. #DOB2=30/06/2019 

 

 
 

  



For the purposes of demonstrating the new Specific Date function, we entered #DOB2=30/06/2019  

Once the change has been made, press the “Save” button on the bottom-right corner of the window. 
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Go to the POS screen and add a Customer to the sale, then add the Membership Stock Item to the Sale. 

 

 
 

Press the ENTER button, then tender the sale. 

The DOB2 field will be updated with the new DOB2 as configured in the Sales Prompt field of the Membership Stock 

Item. 

  



To confirm that the DOB2 has been updated, add the Customer to the sale, then press the “>>>” button at the top of 

the screen. The Customer details will be displayed and will include the updated Birth Date 2: 

 

 
 

If required, additional functions can be configured for the DOB2 field. 

Refer to: Setup > Global Options > Customers > Customer Date Function. 

These are outlined in further detail in the Global Options > Customers topic in the User Guide.  

https://userguide.idealpos.com.au/#Global Options/Customers.htm
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Stock Purchases 

Send Unprocessed Purchase Orders to Stock Item Labels 

This function adds the ability to send any Unprocessed Purchase Orders to Stock Item Labels. 

This can be useful when labels for Stock Items need to be printed before an order is processed or finalised. 

 

To access this function, go to: Transactions > Stock Control > Stock Purchases 

Select the Stock Purchase which contains the Stock Items that require Stock Item Labels to be printed then press the 

“Labels” button.   

 

  
 

The Labels screen will be displayed and any Stock Items that were in the selected Purchase Order will be ready for 

printing.  

Select the required options for printing the Labels, then either press “Preview” to Preview the Labels, or press “Print” to 

Print the Labels. 

 

  



Stock Transfers 

Stock Transfers to Different Items – Option to Update Cost based on Source Item 

This function enables the ability to update the Cost of the destination Stock Item using the Cost of the source item 

when transferring stock between items. This function is useful in cases where you need to transfer stock from one item 

to another (where the source item has a different cost price to the destination item), then need be able to accurately 

report on the actual cost of the destination item, factoring in the cost of other items that were transferred to the 

destination item  

 

To use this function, go to: Back Office screen > Transactions > Stock Control > Stock Transfers 

 

Enter a Reference and the Details of the Stock Transfer, then press the “Add” button: 
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On the following screen, select the Source Location, Stock Code and Quantity from the Transfer Source section. 

After selecting the Transfer Source, the Transfer Destination will be pre-filled with the same Stock Code and Quantity 

as the Transfer Source. 

In the Transfer Destination section, select the Destination Location and enable the “Allow Transfers between items” 

checkbox. By enabling the Allow Transfers between items checkbox, the Stock Code in the Transfer Destination can be 

modified so that you can transfer stock from one item to another (e.g. Transfer Stock from Stock Item Vodka 700mL to 

Stock Item Vodka 1125mL). After you select a different Stock Item in the Transfer Destination compared to the Stock 

Item in the Transfer Source, an “Update Cost” checkbox will become visible. To update the Cost of the Destination Item 

using the Cost of the Source Item, ensure that you tick the “Update Cost” checkbox. 

Finally, press the “Save” button on the bottom-right corner to save the Stock Transfer to the transfer batch. 

 

 
 

You may repeat the above process if you want to transfer multiple Stock Items, otherwise, close the screen to return to 

the screen showing all the Stock Items in the Stock Transfer batch. 

  



To process the items in the Stock Transfer batch, press the “Process” button on the bottom-right corner of the window. 

 

 
 

After the Stock Transfer batch is processed, the Stock Transfers window will remain on the screen and any items in the 

batch will be cleared from the list. 
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When running any reports relating to the destination Stock Item that just had stock transferred to it, or when viewing 

the destination Stock Item, the Average Cost will now be updated using the cost from the source item. 

This can be confirmed by running a Stock Valuation Report on the item (Reports > Stock Control > Stock Valuation) 

and/or opening the Stock Item (File > Stock Control > Stock Items) and viewing the Average Cost. 

 

The Stock Valuation Report will show the updated Average Cost and Stock Value: 

 

 
 

The Stock Item will also show the updated Average Cost as shown below: 

 

 
 

Please note that when the Average Cost is calculated and updated, it is calculated based on previous purchase costs of 

the item. This means if the destination item that the stock was transferred to has no purchase history, the Average 

Cost will drop to the same cost as the source item. If there is purchase history recorded against the destination item, 

the previous cost of the destination item will be used when Idealpos calculates and updates the Average Cost. 

  



Users 

Alternate Codes Modify/Delete User Permissions 

This function adds the ability to allow or deny a User’s access to the Modify Alternate Codes and Delete Alternate 

Codes features in the Stock Items screen. Denying or allowing access to these functions may be useful in environments 

where specific staff are only permitted to update or Delete Alternate Codes. 

 

To configure access to Alternate Codes, go to:  

Setup > Users > Select User > Modify > File > Stock Control > Stock Items > Check/Uncheck Delete Alternate 

Codes/Modify Alternate Codes > Save. 

 

   
 

Once the desired changes have been made for the selected user, press the “Save” button. 

Repeat the above process for any remaining users which need access to these functions modified. 

 

Close the Users screen, then go to: File > Log Out 

Login as a User which the Delete Alternate Codes/Modify Alternate Codes functions were disabled. 
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Go to File > Stock Control > Stock Items > Select Item that contains Alternate Codes > Alternate Codes 

 

 
 

After pressing the “Alternate Codes” button, the Alternate Codes are displayed and access to the Delete/Modify 

buttons is either greyed out or available, depending on whether the user has permission to access those functions. 

 

 
 

  



Stock Transfer Reports – User Permission to Show/Hide Cost 

This function adds the ability to control whether a User has access to the “Show Cost” button when running the Stock 

Transfer Report. When this option is disabled for a User, the “Show Cost” button will be greyed out and when running 

the Stock Transfer Report, the Cost will be hidden from the Report. 

 

To configure this option, go to: Setup > Users > Select User Name > Modify  

 

Under Reports, expand Stock Control > Stock Transfers 

To disable access to the Show Cost function, clear the tickbox for the “Show Cost” option 

 

 
 

To save changes, press the “Save” button on the bottom-right corner. 
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Go to File > Log Out 

Login using the Username which the Show Cost setting was disabled. 

Go to: Reports > Stock Control > Stock Transfers 

 

The “Show Cost” option will be greyed out and unavailable 

 

 
 

  



When running the Report, the Cost is also hidden. 
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User Permission to Hide Stock Item Sales button on Journal Enquiry function from POS 

This function adds the ability to hide the Stock Item Sales button when accessing the Journal Enquiry function from 

POS screen. 

This may be useful in cases where you need to restrict either a single Clerk or all Clerks linked to a specific User from 

accessing the Stock Item Sales button. 

When a Clerk has access to the Stock Item Sales button and they press it, the Stock Item Sales Report for the current 

day will be displayed.  

When a Clerk does not have access to the button, the button will be completely hidden, preventing access to this 

function. 

 

That this function can be configured in one of the two ways: 

• All Clerks linked to a User (all Clerks linked to a User are restricted from accessing the function) 

• Per-Clerk basis (specific Clerks linked to a User are restricted from accessing the function) 

 

Before configuring this function, note that any permissions configured against a User supersede permissions that are 

configured for a specific Clerk. 

 
To configure this function for all Clerks that are linked to a particular User, first, you will need to determine which 
User the Clerks are linked to. 

 

  



Go to: Setup > Clerks 

Each Clerk will be linked to a User and this is determined by the User Link column as shown in the below example. 

A User Link can be modified by selecting a Clerk then clicking on the “Modify” button on the bottom-right corner of 

the screen. 

 

 
 

 
Once you have established which User the Clerks are linked to, go to: 

Setup > Users > Select User Name > Modify 

Under the POS section, expand Journal Enquiry then uncheck the “Stock Item Sales” option. 
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After the change has been made, press the “Save” button on the bottom-right corner of the Users screen. 

Close the remaining Users screen. 

This function will be disabled for all Clerks that are linked to the above User. 

  



To disable access to this function on a per-Clerk basis, go to: 
Setup > Clerks > Select the Clerk > Permissions 
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Under the POS section, expand Journal Enquiry then uncheck the “Stock Item Sales” option. 

 

 
 

This will disable the function for only the selected Clerk. 

Note that the permission which has been assigned to a specific Clerk will override the permission that has been 

assigned to the User that a Clerk is linked to. 

E.g. Clerk “John Smith” is linked to User STAFF. 

When access to Stock Item Sales is disabled for Clerk “John Smith” but Stock Item Sales is enabled for STAFF. 

Clerk “John Smith” will not have access to the Stock Item Sales function. 

Any other Clerks that are linked to the STAFF user will continue to have access to the Stock Item Sales function. 

 

Also note that permissions configured for a User will supersede the permissions that are configured for a Clerk. 

E.g. If the Stock Item Sales function is disabled for a User and you try enabling access to this function for a Clerk linked 

to the User, the Clerk will not have access to the function.  



The Stock Item Sales function is accessed via the Journal Enquiry function within the POS screen.  

You will need to ensure that you have a Journal Enquiry button on the POS Screen. 

To configure this, go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

 

In the Demo Database, this function is listed on the MANAGER tab of the POS Screen, however, you may choose to 

add it to any desired tab. 

Select a tab on the bottom of the POS Screen, then find a blank button and select it. 

The Journal Enquiry button is configured as follows: 

 

 
 

Once you have ensured that a button to the Journal Enquiry function exists, open the POS screen. 
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Enter a Clerk ID which does not have access to the Stock Item Sales function, then click on the “Journal Enquiry” 

button. 

 

The Stock Item Sales button will be hidden from the bottom of the Journal History Enquiry screen. 

 

 
 

Close the Journal History Enquiry screen. 

Enter a Clerk ID which has access to the Stock Item Sales function, then click on the “Journal History Enquiry” button. 

The Stock Item Sales button will be displayed and available. 

 

 
 

  



Yes/No Options 

Yes/No Option – Force Customer Entry On Coupon Redemptions 

When the Yes/No option “Force Customer Entry On Coupon Redemptions” is enabled, Idealpos will check to see if a 

Customer has been added to the sale when redeeming Coupons. If a Customer has not been added to the sale when 

redeeming Coupons, it will force the Customer to be added. This function is applicable to both Serialized Tracking 

Coupons and Print Only Coupons. 

 

For more information about setting up Coupons, please refer to the Coupons Topic in our User Guide - 

https://userguide.idealpos.com.au/#Coupon Promotions/Coupon Promotions.htm  

 

To use this function, go to: Setup > Yes/No Options > In the Enter Keyword Search field, enter “redemption” > Enable 

“Force Customer Entry On Coupon Redemptions” 

 

 
 

  

Close the Yes/No Options screen, then go to the Idealpos POS screen. 

 

A Coupon can be redeemed at any time during the transaction. This is done by scanning a Serialized Coupon Barcode 

or entering the Serialized Coupon barcode followed by pressing the Coupon Promotion button on the POS Screen.  

Alternatively, the Coupon Promo Code can be manually entered from a Print Only Coupon followed by pressing the 

Coupon Promotion button on the POS Screen to apply the coupon. 

 

After a Coupon is added to the sale, the Idealpos POS screen will show the Coupon description at the top of the sale 

screen. 

 

 
 

  

https://userguide.idealpos.com.au/#Coupon Promotions/Coupon Promotions.htm
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Add Items to the sale then redeem the coupon. Items will appear in the sale screen and the coupon discount amount 

will be shown on the sale screen. 

 

 
 

Finally, press the Enter button on the POS screen which would normally take you to the Tender screen.  

However, as a Customer has not been added to the sale and the Force Customer Entry On Coupon Redemptions 

Yes/No option is enabled, Idealpos will show the following prompt: 

 

 
 

  



Pressing the “No” button will return to the Sale screen. 

Pressing the “Yes” button will take you to the Customer Search screen 

 

 
 

Select a Customer from the Customer Search. Idealpos will then display the Tender screen, including the selected 

Customer. Select a Tender method/amount to finalise the sale. 
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Yes/No Option – Hide Alert Level Warnings 

This option will hide the warning that stock item alert levels give when they reach the alert level trigger (and beyond). 

 

To enable this option, go to: Setup > Yes/No Options > In the “Enter Keyword Search” field, enter “hide stock” > 

Enable “Hide Stock Item Alert Level Warnings” 

 

 
 

Close the Yes/No options screen to save the change, then go to: File > Sales > Stock Item Alert Levels 

Select a Stock Item from the list, then press the “Modify” button on the bottom-right corner of the screen. 

Alternatively, you can press the “Add” button on the bottom-right corner to setup a new Alert Level for a Stock Item. 

 

 
 

  



Ensure that the amount entered in the Remaining field is less than or lower than the amount entered in the Alert Level 

field. You may also want to take note of the Stock Code, then press the “Save” button on the bottom-right corner of 

the screen. 

 

 
 

Go to the POS screen and add the Stock Item to the sale by entering the Stock Code or pressing the Stock Item button 

on the POS screen. The Stock Item will be added to the sale and the Alert Level Warning will not be displayed as per 

the Yes/No Option which has been enabled. 

Should you wish to show the Alert Level, disable the Yes/No Option “Hide Stock Item Alert Level Warnings”. 

When the Yes/No option is disabled and an Alert Level Warning is triggered, it will appear similar to the below 

example and will be reflective of the Remaining Level and the Stock Item that triggered the alert level warning. 

 

 
 

For more detailed information about Alert Levels, please refer to the Alert Levels topic in the Idealpos User Guide.  

https://userguide.idealpos.com.au/#Stock Item Alert Levels/Stock Item Alert Levels.htm
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Yes/No Option – Inhibit returning to Home Screen after each sale 

This function adds the ability to control whether the Home Screen will be displayed after each sale. 

This may be useful in environments where a Clerk needs to stay signed in when serving multiple customers, but after 

they walk away, the terminal should return to the Home Screen after a pre-set delay.  

 

To configure this function, go to:  

Setup > Yes/No Options > Enter “Home” in the Keyword Search 

Ensure that “Allow Home Screen” is enabled 

Then either enable or disable the setting “Return to Home Screen after Each Sale” 

If Return to Home Screen after each sale is enabled, the Home Screen will be shown after each sale is completed.  

If Return to Home Screen after each sale is disabled, the Home Screen will not be shown after each sale is completed. 

 

 
 

  



If you disable the option “Return to Home Screen after Each Sale”, you have the option to configure a Clerk Timeout 

where Idealpos will automatically display the Home Screen after a period of inactivity (note that this will only occur if 

there are no items added to a sale and the POS screen is left to idle). 

To configure this, ensure that “Return to Home Screen after Each Sale” and “Compulsory Clerk” are both unchecked in 

the Yes/No options, then close the Yes/No options and go to:  

Setup > Global Options > General > Clerk Timeout 

Enter the desired timeout in seconds. Setting the Clerk Timeout as 0 will result in no timeout.  

The below example shows a timeout of 60 seconds (1 minute).  

Close the Global Options window to save changes. 
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In order for these changes to apply, Idealpos will need to be restarted.  

Open IPSUtils (open the Windows Start Menu and search for IPSUtils), tick the option “Close IPS Utility” then press the 

“Close” button within the IPS Utility.  

 

 
 

Once Idealpos has closed, you may start Idealpos again and the changes will now take effect.  

From the Home Screen, enter a Clerk ID or select a Clerk Image to login to Idealpos. 

Add items to a sale, then finalise the sale by taking payment. 

 

If the “Return to Home Screen after Each Sale” option is disabled, the sale screen will appear after completing a sale. 

If you configured a Clerk Timeout other than 0, the POS will automatically display the Home Screen when there are no 

items added to the sale and the timeout period lapses. 

If the Return to Home Screen after Each Sale option is enabled, the Home Screen will appear after completing a sale.  



Yes/No Option – Inhibit selling of items not Enabled in Location 

This function will restrict the user from selling an item that is not enabled in the current location. 

When the user attempts to sell an item that is not enabled in the current location, a prompt will be displayed and the 

item will not be added to the sale. This function may be useful in cases where a Location within a venue is not 

permitted to sell restricted items such as Alcohol or Tobacco, but other locations at the venue are allowed. 

 

To use this function, go to: Setup > Yes/No Options > In the Enter Keyword Search field, enter “inhibit sell” 

 

 
 

Close the Yes/No options screen. 

Your POS Terminal Description and POS Terminal Code is displayed at the top of the Idealpos screen: 

 

 
 

Once you have determined the POS Terminal Description and POS Terminal Code, go to:  

Setup > POS Terminals > Locate your POS terminal in the list 

The POS Terminal Location is displayed in the Location column: 

 

 
 

Close the POS Terminals screen, then go to: File > Stock Control > Stock Items 

Search for a Stock Item that is not enabled in the current location which your POS terminal is located. 
To view the list of Locations that a Stock Item is enabled in, search and select the Stock Item so that it is highlighted, 
then press the “Locations” button at the bottom-right corner of the Stock Items screen. 
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A list of Locations which the Stock Item is enabled at will be displayed: 

 

 
 

If you want to disable the item in a Location, it needs to be removed from that Location by selecting the Location and 

pressing the “Delete” button. Note that the Stock Location entry also contains Stock Level data that is associated with 

it. It is only possible to delete a Location from a Stock Item if the Stock Item’s Stock Level is zero, otherwise Idealpos 

will display a prompt and prevent you from deleting the Location. Therefore, the existing Stock Levels in a Location will 

need to be transferred to another Location. Please use caution when transferring Stock between Locations and 

modifying Stock Item Locations, and take note of the Stock Levels of any item that you are modifying. 

For more information about transferring Stock Levels between Locations, please refer to Stock Transfers in the 

Idealpos User Guide here - https://userguide.idealpos.com.au/#Stock Transfers/Stock Transfers.htm  

 

Once you have either identified a Stock Item that is not available or moved a Stock Level to another Location and 

removed the current Location from a Stock Item, go to the POS screen. 

 

When selling a Stock Item that is not enabled in the Current Location, Idealpos will display the below prompt: 

 

 
 

This will prevent the sale of the Stock Item in the current Location.  

https://userguide.idealpos.com.au/#Stock Transfers/Stock Transfers.htm


Yes/No Option – Warn when selling Items not enabled in Location 

This function adds the ability to enable a warning when selling items that are not enabled in the current Location.  

When a Stock Item is not enabled in the current location and the operator tries to sell the item by either scanning the 

Stock Item barcode, entering the Stock Item Code or pressing the Stock Item button on the POS screen, Idealpos will 

display a warning that the item is not enabled in the location and will ask the operator if they are sure they want to 

add the item to the sale. The operator will then have the option to press “Yes” to add the item to the sale, or they can 

press “No” to cancel adding the item to the sale. If the operator chooses to add the item to the sale, the item will be 

enabled in the location only after the sale is finalised; this means if the item is added multiple times to the sale, the 

prompt will be displayed each time the item is added, however, the prompt will not appear in any future transactions 

which the item is sold. In the event that the operator chooses to add the item to the sale but they then void the entire 

sale or void the item from the sale, the item will not be enabled in the location. 

 

To use this function, go to: Setup > Yes/No Options > In the Enter Keyword Search field, enter “enabled” > Enable 

“Warn when selling Items not enabled in Location” 

 

 
 

Close the Yes/No options screen. 

Your POS Terminal Description and POS Terminal Code is displayed at the top of the Idealpos screen: 

 

 
 

Once you have determined the POS Terminal Description and POS Terminal Code, go to:  

Setup > POS Terminals > Locate your POS terminal in the list 

The POS Terminal Location is displayed in the Location column: 
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Close the POS Terminals screen, then go to: File > Stock Control > Stock Items 
Search for a Stock Item that is not enabled in the current location which your POS terminal is located. 
To view the list of Locations that a Stock Item is enabled in, search and select the Stock Item so that it is highlighted, 
then press the “Locations” button at the bottom-right corner of the Stock Items screen. 
 

 
 
A list of Locations which the Stock Item is enabled at will be displayed: 
 

 
 
  



When selling the item via the POS Screen (pressing the Stock Item button or entering the Stock Item Code and 
pressing Enter), the following prompt will be displayed > Press “Yes” to add the item to the sale or press “No” to 
cancel: 
 

 
 
After pressing “Yes”, the item is added to the sale. 
 

 
 
Press the “Enter” button to go to the tender screen > Select a tender amount/option to finalise the sale.  
Idealpos will then enable the item in the current location. 
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Go to File > Stock Control > Stock Items > Search for the Stock Item > Select Item > Press Locations button 
The item is now enabled in the current Location: 
 

 
 
When adding the item to a sale in the POS screen, the Warning prompt is no longer displayed for the item as the 
item is now enabled in the current location. 


